BUG: InnerFocus not activating after CD reduc

Bug Report
Inner Focus is functioning fine on the first cast, both with and without macroes, but after the cooldown has been reduced with Train of Thought, it will not activate with or without use of macroes. I've tried clicking the ability as well as using the macro it's in. The ability is clearly "ready" for use. It lights up when I cast, but then doesn't do anything. As a tank healing disc priest who casts a LOT of greater heals, I would really like to see this fixed. Not having my mana-free gheals is a serious blow to my mana conservation. Why spec into the talent if the talent is bugged? >.> Please help.

EDIT: It DOES activate after the standard 45sec cooldown ellapses. But again, what's the point of having the talent if I can't have the cooldown reduced. Also, this only seems to happen while in combat. I've had it work fine while spamming heals on myself in Org. Edited again because I confuse my spell names x.x
Inner Focus is broken for me too.

This is a dreadful bug for Discipline priests:

I have had the same problem with the spell not working when it is clearly ready to be cast.
It is random and seems to only happen to me when in combat. I have tried using it with macros and going macro free and the outcome in raids is still the same with it freezing up and becoming unusable. I have the spell on my bars and watch for it to become non-greyed (ready to be cast), but when I click on the spell nothing happens.
Last night during Omni Defense System it started out fine and then locked up for almost the rest of the fight, it only freed up right at the end.
This is frustrating as this wastes a huge chunk of mana...I even talent to have this spell's cooldown reduced, so please fix it!!!

*I have looked at all the other threads in the priest forums as well as here and could not find a BLUE response. If I missed the bluepost, would someone please link it for me?

It would be nice for some sort of acknowledgement so that we know
A) you know that this is not working as intended
B) you have plans on fixing this

Thank you
I too am having this issue.
Same here. There are a number of posts on it. Hopefully it gets fixed soon.

Join the Conversation

Return to Forum