Updated to Windows 10 and right mouse button view is erratic.

Technical Support
Using the right mouse button to look around will now cause the camera to move in very extreme ways. One slight movement will result in looking up at the sky and a lot of twirling. Completely unable to adjust camera in to any viable angle.

Disabled all addons and problems still exist.

Please advise. Ruining my ability to play at the moment.
The current version is beta. The release version is still a day away. If you just installed it means you need to update it to current version.
Marked As Solution
Fixed it, delete your WTF folder or rename it and let WoW make a new one. Works fine now.
Switching to fullscreen then back to windowed fixed the problem for me.
07/29/2015 07:00 PMPosted by Junipir
Switching to fullscreen then back to windowed fixed the problem for me.


Fullscreen and then back to Windowed fixed the issue for me, too...
windowed to full screen to windowed fixed it. thank gawd (gawd does not mean god). been going mad trying to find this on the internet.
Experiencing this issue on the release build. None of the fixes in this thread have helped. I'm using a Logitech M570 wireless mouse w/ latest SetPoint.
Best to create your own thread as this one is considered resolved.
And so I did! TL;DR Uninstalling Razer synapse fixed it for me.

http://us.battle.net/wow/en/forum/topic/18300017371
Had the same problem, go into your WoW folder. Right click on the WoW executable and click properties, tick the box for "Disable display scaling on high DPI settings" this has fixed it for me. Hope it helps!
~ Asparn (http://eu.battle.net/wow/en/forum/topic/15162420424)

This method has worked perfectly for me. I also noticed the graphics were a bit fuzzy/blurry when updating to Windows 10, and this method fixed this issue for me as well.
I would like to add to this forum as I have found a solution in what has been suggested by Shuai. My friend and I both had updated to Windows 10 and updated our setpoint program for or mouse's his was a Logitech G330 gaming mouse mine is a Logitech MK 550 combo mouse and we both had experienced the same issue.

After having deleted the WTF folder the camera pan issue resolved itself. To me this suggests that within the WTF folder there was a configuration setting that was previously only compatible with Windows 7 and Windows 8 within the folder that after having upgraded to the new setpoint caused a glitch with the information in that file/folder (WTF). By deleting the WTF folder the mouse panning issue has resolved itself for both of us.
08/31/2015 10:08 AMPosted by Charride
I would like to add to this forum as I have found a solution in what has been suggested by Shuai. My friend and I both had updated to Windows 10 and updated our setpoint program for or mouse's his was a Logitech G330 gaming mouse mine is a Logitech MK 550 combo mouse and we both had experienced the same issue.

After having deleted the WTF folder the camera pan issue resolved itself. To me this suggests that within the WTF folder there was a configuration setting that was previously only compatible with Windows 7 and Windows 8 within the folder that after having upgraded to the new setpoint caused a glitch with the information in that file/folder (WTF). By deleting the WTF folder the mouse panning issue has resolved itself for both of us.


That's possible, but it's tough to say.

It's possible that the default meanings of the various SetPoint options have been altered for their Windows 10 usage.

In general, most of what WoW does with such hardware is generic, so clearing the WTF would only reset any user adjusted settings back to their defaults. It could be that once a particular ingame setting is once again updated, the problem(s) will return.
08/08/2015 11:23 AMPosted by Søulstorm
Had the same problem, go into your WoW folder. Right click on the WoW executable and click properties, tick the box for "Disable display scaling on high DPI settings" this has fixed it for me. Hope it helps!
~ Asparn (http://eu.battle.net/wow/en/forum/topic/15162420424)

This method has worked perfectly for me. I also noticed the graphics were a bit fuzzy/blurry when updating to Windows 10, and this method fixed this issue for me as well.


This is what worked for me after updating to Windows 10. Don't forget... If you have a 64-bit OS, you need to change the settings on the WOW-64.EXE so that it will work when run from the Launcher.
The fix of changing the WOW-64.EXE did the trick thanks so much.
On patch 6.2.3, but still same issue. Tried WTF method, DPI method, and scan/fix method. Still not working on Win 10.
Yup,

Just recently went to Win 10 and also having similar problems. Clicking or right-click camera panning, the camera goes out of control. Tried clearing the config.wtf and the dpi method, neither worked.
07/10/2016 06:37 PMPosted by Priss
Yup,

Just recently went to Win 10 and also having similar problems. Clicking or right-click camera panning, the camera goes out of control. Tried clearing the config.wtf and the dpi method, neither worked.


If you did a upgrade install then that could very well be a lot of your issues. there is no such thing as a "good " upgrade install. After the upgrade install its actually a good idea to download windows 10 to a thumb drive and format the OS drive and do a clean install.

I would start with uninstalling any mouse drivers and reinstall them. Also you have to download all the drivers for your computer they do not come with windows 10 and the precious versions are not 100 percent compatible with windows 10
Turned out that the issue was Symless (A third party program that allows one computer to control other computers like additional desktops) needed to be reinstalled. It worked normally for everything but apparently causes the 'spastic' behavior in Wow. Had no problems in other games hence it not being noticeable until I tried another profile where symless wasn't running 100% and was able to play wow without an issue, but on another profile trying to treat the profile as possibly corrupt (And for other reasons), seeing it go spastic while symless was running.

The host computer (gaming) was running the Symless host. Just did a repair install and seems stable now.

[Solved]

Join the Conversation

Return to Forum