Trouble... Mouse Lag, don't understand it?

Technical Support
Ok, so my computer is a custom computer I've just built, and it's ran WoW Just fine no problem there... Well my wired mouse died, so I had to get a new mouse, and was forced to buy a wireless mouse, now I seem to get Mouse Lag ONLY while playing WoW... Like I'll be highlighting over something, and the mouse will get held up and wont move for a sec or 2...

What's going on... Only happens in WoW... I'm getting 120 FPS in the game....
I'm having the same issues. I can't find anything to remedy it. I'm considering buying a new mouse but I'm doubtful that it'll fix anything
Whole,

Have you tried the Reduce Input Lag setting under the video options in-game?

It could also be related to an addon, so you may want to try disabling them and see if it takes care of it, then re-enable them one by one to see which one it is.


________________________________________________
Account and Technical Services
Mon-Fri 12pm-8pm
Feel free to rate my services at the following link: https://www.surveymk.com/s/T8S7BX2

"A working class hero is something to be"
I am having a similar problem. I have no addons running whatsoever, and I have already enabled the "Reduce Input Lag" setting under video options. I dont have a clue about how to proceed. Any ideas?
i had the same problem. no add-ons, "RIL" on.
what finally fixed the problem was going into "controll panel", then "hardware and sound", then to "mouse". now, under the "pointers" tab uncheck "allow themes to change mouse pointers" and "enable pointer shadow"
so far this has worked for me
Hey i have the same problem on my new computer and i was reading a bit and found out the aluminum of my new computer messes with the signal of the mouse because it works fine when my mouse is on the side of the usb device. Although this problem only happens when i play wow.
I'm running into the same issues. The only thing i recently changed was when I attempted to use a Logitech wireless keyboard, and added the Logitech gaming mouse (G300). Everything ran fine, I updated the drivers from Logitech etc to ensure there would be no issue, etc. Then i logged into WoW and instantly discovered something is wrong. The game plays fine....unless i move the mouse in anyway. Then the whole game will lock up. If I'm steering via the keyboard, there is no issue and everything looks normal. If i sit there and swirl the mouse in circles it completely locks up the wow interface like a lag.

I've updated the in game settings for RIL, disabled all addons (i was REALLY hoping this was the issue), taken off all Logitech devises and uninstalled all the related drivers, changed my mouse pointer thingie options for the shadowing effect like Baalshemtov mentioned....nothing.

And of course, this is only impacting my system in ANY way when i'm playing WoW (which accounts for about 85% of my online time).

Any help here guys?
The comment on aluminum in new PC interfering with mouse signal because mouse is used on opposite side from usp port solved the mouse lag problem for me. I just switched to the port on the side where I use my mouse. Yay!
I switched to a steel series WoW mouse as well because i dont have enough binds for healing X_x in beta. Same problem, random lag at times. Why is this so common with steel series WoW mouse?

it is very bugy, some times I loose all the extra buttons in game
I recently built a new system...EPIC graphics (dual GTX680), SSD hardrive, 16gb ram, 25" IPS 6ms...and razor blackwidow keyboard with razor hex naga mouse. Guesswhat...

HUGE lag spikes on mouse use when trying to move...and it's random...I'll be in a BG and try to push left and right mouse button to run at a target..and nothing..my toon stands there until I use the keyboard to move then after a few keyboard inputs the mouse seems to come back and I can use the right and left mouse down buttons to move again.

Thoughts?
This thread is a couple years old. :o

Have you tried the suggestions in it?
yeah I tried them all...I'm about to take the computer in for a 150.00 diagnostic with all my peripherials..I even tried my old G5 mouse and it's doing it too...it's only in WoW though.

I"ve set RIL...tried syncing to framerate...not syncing to framerate...

The other thing I'm noticing is if I mount up...set my toon to auto run...and after a bit try to steer by dragging the mouse...I get nothing..it takes sometimes 3 to 4 clicks and drags to get the toon to turn directions.
FIXED IT!

What I did.

In the Razor Synapse 2.0 software I went into Mouse Performance and set the Dots per inch to 2500 and the polling rate to 500

The laggy feeling of the mouse is gone and I love it...no more unresponsive or hanging mouse on movement.
I got rid of my lag by disabling "Hardware cursor" in Game Menu > System > Advanced.
I know this thread is a couple years old but Im having the same problem with my logitech M510 wireless mouse only when playing WOW. Ill be mousing around fine and then all of a sudden its like the mouse just stops in mid drag. hesitates then starts again. On the IMAC I do not find anything that results in allowing shadows on pointers.

All add ons are off. Just enabled adjust for mouse lag and hardware adjust for mouse lag. though I note both say "unless you have cursor problems".

Seems a little better in the first 5 minutes of play. Ill adjust my reply if it fails. fingers crossed.
Same issues, and ONLY in WoW.

Some days are fine and others are really bad.

The only thing that seems to solve it is switching USB ports.
OK

I think I found a solution for people using a Logitech M325 although I'm sure this would work for any M model.

http://support.logitech.com/en_us/product/wireless-mouse-m325

Download the SetPoint application. This gives you much deeper customization with the mouse. I believe it overrides the built in mouse settings which seemed to make my mouse feel much better all around.
FYI, since this post is going on a year old. I'm having the SAME troubles. Logitech wireless mouse that locks up in game play but no where else. It's not quite as bad in the current WoD expansion, but in the Legion alpha it's horrible. So obviously this is a game-related issue and how it interacts with wireless mice.

I've tried all the suggested settings changes and certainly no addons installed. I've replaced batteries, moved the USB dongle to different ports. I thought that it may be a cellular device (phone or tablet) interfering with signal, but that wouldn't just happen in-game.

Personally I think this is connected in some way to graphics. I think it's either a memory leak or some other issue that happens in the GUI which interferes with the mouse's ability to function. But I'm no expert. Also, the longer I play, the worse it gets, which again tells me that it's memory-leak or overburdened CPU related.

I've even turned all my graphic settings down to the lowest, off, or disabled, and it doesn't help. I've turned them up to max...no help. I'll try the mouse adjustments suggested by Brewsleeh a few posts above.
I think its time to get rid of WOW since they cant seem to fix the issue or let any one know of how to fix it.. been having this problem for a LONG Time and still cant fix it...
just wanted to chime in. I have the exact same issue. I am using a logitech M510 wireless mouse. full batteries and updated drivers. My mouse randomly stutters in the game. if i rotate the camera by holding down the right mouse button while i move it, it will randomly pause the motion and the cursor will reappear on the screen.

This doesn't appear to happen in FFXIV or EVE online, only wow...

Has anyone actually filed a bug report yet?

EDIT: yes, i have tried all the suggestions listed i this thread. took me all day :/ no results

Join the Conversation

Return to Forum