Launcher Won't Start Up

Technical Support
As stated in forum title, my WoW launcher will not start up. I click the Desktop icon and it shows the little blue circle above my mouse for about half a second before doing absolutely nothing... I've tried restarting my computer and opening the launcher quickly and it opens breifly and begins downloading the new patch before the "Connection Timed Out" error window pops up and the launcher closes. I believe it has something to do with the new patch but i have no idea how to fix it. Help please?
Let's try a Selective Startup first, and we can work from there:

Hit the Windows Key + R, and type:
Hit Enter or OK.

In the General tab:

1. Choose Selective Startup
2. Disable (uncheck) Load Startup Items
3. Click on the Services tab
4. Check "Hide All Microsoft Services"
5. Click on "Disable All"
6. Click OK and Reboot
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly:
'Black holes are where God divided by zero.'
Rate Me!
Thank you for the advice. Unfortunately, the Launcher will load up once, "Connection Timed Out", close and refuse to start up again.
I'm having the exact same problem. Started after I tried downloading the patch yesterday.
Same issue here too, started happening after i tried downloading new tools
Same Issue. It was saying 'Downloading Updated Tools' Then about halfway through it brought up 'Connection Timed Out' and closed and now it won't open at all. I tried what the blue post said but it still won't open.
Alright! Well, I got it to update and install the patch. All you need to do is go into your World Of Warcraft folder and open up 'WoW.exe
You can just type any Username and password and it will say downloading updater and then patch required. And then just press the button and it should install it fine. It seems to have taken away the launcher problem because I can open launcher again just fine.
Hope this help :D
OMG ty ty ty helped tons :D
Thanks for the blue post. It fixed my problem.
Ah, blue post worked perfectly, thank you so much for the help david
Can someone also help me,

The situation on my computer is similar but not the same. I click on my WOW launcher and within a minute a there is this thing that pops up on my screen that said that it won't launch because of my internet configuration yet my my internet is completly fine. I tried every thing: restarting my computer multiple times and trying, Clicking on the folder, unpluging my router, ETC. Nothing is working. Im extremly frustrated and I don't have a clue what to do. This is truly a great game but I cannot play it. Can somone please help me.

What happens when you try to log in, Henrydaman?
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly:
'Black holes are where God divided by zero.'
Rate Me!
There is this world of warcraft thing that pops up that says that my internet configuration is not responding yet my internet is fine. this happens everytime I press the launcher on my folder or on my screen.

Can you check this in Control Panel, in Internet Options?

Go to the Connections tab.

Click on LAN Settings

Make sure these are Unchecked:

  • Use automatic configuration script

  • Use a proxy server for your LAN

Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly:
'Black holes are where God divided by zero.'
Rate Me!
Same thing happens to me, i click the wow launcher and. yes ive tryed as the administrator open one also. and it just puts a blue circle arround my mouse for about a second, (after i click play) and nothing happens, i already tryed re downloading it. and same thing happens. Please help? ty.
I'm have a similar problem, i click on the WoW icon, it comes up for about 1 second, then it disappears. It's really frustrating, seeing how a virus has done something to my C: local disk.
I can't go into the WoW folder to 'repair wow' because it says "This folder is empty" when i try and go into 'C: local disk' how else can i get it to start up?
I get the launcher up but the loading bar says waiting on other downloads it won't let me click the play button, it stays dark what do I do?
I have a MAC. Every time I launch it opens for a second and then closes again.....Is there a way to fix this??
I'm having similar issues. At first I was thinking the game just wouldn't launch.
After hitting play it says game is running and nothing happens...until you wait 3-5 minutes.
Game finally opens up then.
Tried the selective startup. Had no affect.

Internet options are as they should be.

Any way to get the game to launch quickly and properly?
Okay everytime I press play to start up wow it freezes and doesn't let me do anything at all

Join the Conversation

Return to Forum