Microsoft Visual C++ Runtime Library Error.

Technical Support
So I'm downloading the new tools and about mid way through it shuts down on me. So I attempt to restart the launcher and I get that error ^^. It reads,

"Runetime error!

Program: C:\Users\Public\Games\World of Warcraft\Launcher.exe

This application has a requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."

I've already uninstalled all my virus and firwall software and nothing works. I'm stuck. Help please.
same problem here...

its quite annoying =/
bump
Glad to know I'm not the only one having this problem.
T-weird g try running it as admin looks like it worked for me
I'm having the same problem, HELP!
like Jigledogle said run as admin.
Same...wont work been trying everything
I am experiencing this as well. It seems to also happen to the PTR.
running as admin isn't working for me. also I tried several other 'fixes' i found in forums here and other resources and nothing seems to work... /discouraged
Glad to know i'm not the only person this is happening to
Tried to repair but no go
likewise. gah! hope someone has a solution soon
someone try a virus scan
These updates from Microsoft may help:

Microsoft .NET Framework 3.5 Service Pack 1

http://www.microsoft.com/downloads/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&displaylang=en

Microsoft .NET Framework 4

http://www.microsoft.com/net/Download.aspx

Microsoft Visual C++ 2005 SP1 Redistributable Package (x86)

http://www.microsoft.com/downloads/details.aspx?familyid=200b2fd9-ae1a-4a14-984d-389c36f85647&displaylang=en
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'Black holes are where God divided by zero.'
Rate Me! https://www.surveymk.com/s/R6BG5YS
is there any special concern i should have with running the shortcut as the administrator?

because as long as i run the shortcut as the administrator it runs fine, or if i dont log on with a guest account - it runs fine.

otherwise i get the runtime error.

i followed all of the fixes listed above, and only access the files as an administrator helped.

something just seems wrong with that to me.....

what do you guys think?
I don't think you should have to run as admin in order for it to work something is up if we're all suddenly having this problem at the same time. The blue support didn't help me out at all
What version of Windows are you running?
________________________________________________
Account and Technical Services
If the Forum isn't helping, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
'Black holes are where God divided by zero.'
Rate Me! https://www.surveymk.com/s/R6BG5YS
What David did for me was that he told me the same things witch is what he told you to download, i did soo and didn't work. so he just directed me to a link to download the patch instantly so maybe this will work also with the Hotfix.
Vista

Join the Conversation

Return to Forum