BattleNet Launcher is screwing up

Technical Support
It's going crazy. It keeps disconnecting and then taking forever to reconnect. It would be fine if it didn't kick me from certain games! What is going on?!
Mine is doing the same thing as well so it's not just you. Hope it fixes itself soon.
having the same issue cant log back on
Mine is also messed up...keep getting disconnected
I'm receiving the same problem here. At least, with the not connecting part, didn't have a chance to disconnect.

I'm guessing Gaben came over for a visit and thought some of the more important wires where noodles or something. Or maybe another hamster died from exhaustion again.
Same thing here.. :(

Glad it's not just me.
Yep, was playing D3 and it kept kicking me out. Reconnect the launcher, login to game, DC within a few seconds. WoW too. All BNet games appear to be affected.

Another DoS attack?
Same here, was kicked off HS after the game & couldn't connect or log in.
Same, Any time frame on how long these usually last for?
11/03/2015 07:43 PMPosted by Calindri
Same, Any time frame on how long these usually last for?


5-45 minutes, give or take how bad the damage is.
Half my guild mid raid dc'd and can't get back in.
EDIT good to go now
Can't log in.
Can see realms, but can't go into mine! I tried and can go into another realm, but not the one with my chars!
US-Dalaran
same prob here also
Been booted a few times today from Bnet only, but game continued. 4 min ago i got booted from the game and now all I can do is keep selecting a realm but no character selection afterwards...
Update for me, I apparently am able to log in now. So that's progress, at least.

Try logging in again, see if you can finally pop back in to kill hogger- I mean do Warcraft stuff.

EDIT: Nevermind, everything halted at 'Logging into Game Server.'

This issue may last quite a while, what with Blizzard preparing their Blizzcon, and taking their attention away from the game.

ANOTHER EDIT: Finally managed to pop in.
11/03/2015 07:52 PMPosted by Omidoo
Can see realms, but can't go into mine! I tried and can go into another realm, but not the one with my chars!
US-Dalaran


Same which is useless I was on the mid of BG where Horde was actually pwning Alliance!!
Same here since Mid-October!! We should all demand refunds :(
Having no problem logging in but game won't launch.. is anyone else having this problem? its been like this for two days now, tried re-installing (30gbs..thanks blizzard) checked forums and this happened heaps...4 years ago, can anyone tell me in detail how to login as admin? its the only thing i haven't tried 'can't right click on "play" icon either- just says "game is running" for about ten secs then nothing! getting real frustrated Please Help Me!

Join the Conversation

Return to Forum