Guild Invites

Bug Report
I tried to invite a current guildies alt to the guild and when I put in his name, I got a message saying that I was already in a guild. I've had another guildie say they had this same issue when they tried to invite someone also.
Confirmed. I'm having the same problem on Ghostlands/Kael'thas
More details...... After sending the invite I get the following two line response

You have invited *friend's name* to join your guild.
*my name* is already in a guild.

I then had the friend make a lvl 1 toon. I was able to invite that character to my guild with no problems. He does not have "block guild invites' checked. Seems to be a character specific problem.
The character likely recently had a faction change.

Try to get in contact with an officer in the original character's guild and have them type "/gremove OldCharacterNameHere" and if that doesn't work, "/gremove NewCharacterNameHere". There's an issue with faction changes currently that leaves the character in their old guild. If you can't get the character removed with this method, open a ticket and a GM will sort it out.

Join the Conversation

Return to Forum