Random lag spikes

Technical Support
For the past month or so I have been getting really random lag spikes. My latency would go through the roof for a few minutes and then back again to my usual latency (200+). During the times I don't get these random lag spikes my connection is great. I can raid/BG just fine.

This started a few weeks after Cataclysm came out. I did not have any internet issues prior to Cata release. I'm not sure what to do at this point..i would like any help that you can give
bump
Sigh... I'm having a very similar problem. Prior to cataclysm I had no problems whatsoever. But after I installed catac, I've been getting this strange freeze lag. I can move around and type without any delay. But everyone else on my screen is frozen for about 5-10 seconds. Then after those 5-10 seconds are up everyone is moving at lightning speed because of the lag. This is especially annoying while I'm in battleground, because as soon as I go into combat.. the freeze lag comes up and when the 5-10 seconds are up, I'm dead. Anyway... if anyone knows how to fix this situation or has the same problem, please share!
For me I get random times when my fps gets down to one. this has never happened before just started two days ago. NEED HELP
Bumping threads from a year ago causes a bit of confusion. If you need assistance with an issue, please create a new thread and detail your issue there. Make sure to include any steps you have already tried.
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!

Join the Conversation

Return to Forum