[Linux] issues with Patch 6.2.4 (Consolidated Issues Thread) R09

Technical Support
Prev 1 15 16 17 26 Next
Just wanted to say thank you to all the people working on this bug. I don't know how to code, or even how to figure out which version of kubuntu I am running, so you are my heroes. <3
Just wanted to say thank you to all the people working on this bug. I don't know how to code, or even how to figure out which version of kubuntu I am running, so you are my heroes. <3


Do you have it working?
Windows 7, same error code.....ive reinstalled bnet/wow, tried 32/64, and basically EVERY other troubleshooting method possible....this is NOT a linux specific error code..

laptop with windows 10, no error at all.
03/25/2016 05:52 PMPosted by Jestes
Windows 7, same error code.....ive reinstalled bnet/wow, tried 32/64, and basically EVERY other troubleshooting method possible....this is NOT a linux specific issue...


Yes, this is a Linux-specific issue. You may be getting the same error message, but it stems from a different cause than the one we have here.

Just because both men and women can get headaches does not mean that all headaches are caused by the same underlying problem; there's a lot of different problems that can manifest themselves in that symptom.
wine32-development 1.7.29-4
Linux 3.16.0-4-amd64
Debian 8.3 (x64)
WoW has been running fine until 6.2.4, then had the "endless connect" issue. Fighting with it since the patch.

All I did to fix the issue (did not re-install anything):
* installed 1.9.6 bundle from winehq (under /opt/wine-devel)
* tried running wow with new 1.9.6 - still failed to connect
* built 64-bit wine from source (git/apply secur32 patch/configure/make)
* built my fixst lxc 32-bit container (yay)
* built 32-bit wine in container (copied patched source dir/configure/make)
* copied new 64-bit secur32.dll.so to /opt/wine-devel/lib64/wine/ (made backup copy first)
* copied new 32-bit secur32.dll.so to /opt/wine-devel/lib/wine/ (ditto)
* fired up WoW - logged right in - zero issues

Much thanks to Sabraen - whose post and cheat-sheet got me the last mile

In the interest of sharing - anyone willing to try these out are welcome to - these archives have the 32 and 64-bit secur32.dll.so - as compile on the system listed above using the secur32 patch - just unzip in your wine top-level install (/opt/wine-devel on my box) - I would suggest backing up the originals first, just in case.
* secur32-64.7z https://drive.google.com/file/d/0B_LQeLFfYgkgcWtrV1pMdjlQU1E/view?usp=sharing
* secur32-64.zip https://drive.google.com/file/d/0B_LQeLFfYgkgZ2lWTS1rd195SlU/view?usp=sharing
Thank you to everyone who has been working this.

I got it working on Mint 17.3 using ppa:wine/wine-builds and coping in Pontudinho's patched secur32.dll.so

Thanks again.
Posted by Pontudinho
I am using Linux Mint 17.3, which counts as Ubuntu 14.04, and was able to connect by manually patching dlls/secur32/schannel_gnutls.c in the Wine source (downloaded from https://github.com/wine-mirror/wine), as instructed by Store.

When building wine, I installed libgnutls-dev and used: ./configure --enable-win64 --without-x --without-freetype so I wouldn't have to install all dependencies. Then I let it compile for a while, just to give it enough time to build secur32.dll.so, and copied it to my wine installation, which is the winehq-devel package suggested earlier. To do this, I replaced /opt/wine-devel/lib64/wine/secur32.dll.so with the new secur32.dll.so I compiled.

I am providing* my compiled patched secur32.dll.so file. Be careful when using it, I think it will ONLY work on Ubuntu 14.04-based distributions AND with the winehq-devel package. And I did not build for 32-bit, only for 64-bit, so I think it will not work for 32-bit wineprefixes.

* Link: https://dl.dropboxusercontent.com/u/46320191/secur32.dll.so

WORKED!!! This patch worked for my 14.04.
I haven't a freaking clue why I can't compile a working secur32.dll.so file myself :@@@
#298
1 hour ago
Like
Reply Quote


Me Too! Thanks all, what a ride.
Mint 17.3 (aka ubuntu 14.04)
03/25/2016 04:32 PMPosted by Pontudinho
I am using Linux Mint 17.3, which counts as Ubuntu 14.04, and was able to connect by manually patching dlls/secur32/schannel_gnutls.c in the Wine source (downloaded from https://github.com/wine-mirror/wine), as instructed by Store.

When building wine, I installed libgnutls-dev and used: ./configure --enable-win64 --without-x --without-freetype so I wouldn't have to install all dependencies. Then I let it compile for a while, just to give it enough time to build secur32.dll.so, and copied it to my wine installation, which is the winehq-devel package suggested earlier. To do this, I replaced /opt/wine-devel/lib64/wine/secur32.dll.so with the new secur32.dll.so I compiled.

I am providing* my compiled patched secur32.dll.so file. Be careful when using it, I think it will ONLY work on Ubuntu 14.04-based distributions AND with the winehq-devel package. And I did not build for 32-bit, only for 64-bit, so I think it will not work for 32-bit wineprefixes.

* Link: https://dl.dropboxusercontent.com/u/46320191/secur32.dll.so


I have Linux Mint 17.2 with 4.4 Kernel and Wine-dev 1.9.6 and your fix did the trick! You are awesome. This is why I love the Linux community. Thank You!
I am providing* my compiled patched secur32.dll.so file. Be careful when using it, I think it will ONLY work on Ubuntu 14.04-based distributions AND with the winehq-devel package. And I did not build for 32-bit, only for 64-bit, so I think it will not work for 32-bit wineprefixes.

* Link: https://dl.dropboxusercontent.com/u/46320191/secur32.dll.so
#297
2 hours ago
Like
Reply Quote


Hey good work man, that worked.... I'm logged in (Ubuntu 14.04 w/ 1.9.6)

Cheers!
03/25/2016 05:04 PMPosted by Allialara
Thread bumped to R07. While I really do appreciate Store's work on the patch and think it's a great solution for people who can't or won't upgrade to a newer version of their platform, I am genuinely uncomfortable recommending this as the first choice.

It works, but being that it's not subject to QR at winehq the patch could have unintended effects on other applications that won't be immediately obvious. Building wine from source is also not a simple solution for the majority of users that don't already know what they're doing (which I suspect is the majority of people reading this thread).

Nonetheless, because it is a working solution, I added references to it in the first post with directions to start reading at page 11 if the reader wants to try it.


First let me say that we all appreciate your upkeep of this thread. I just want to alleviate some fears you have with the patch method. I have tried several x64 WINE apps and they seemed to work with the patch secur32.dll.so file.

Now I get that ALL x64 apps may not work with the patch file but if you know some scripting, you make a temp fix that copies over the original file for certain apps that won't work with the patches one. The key here is to keep a copy of the original file and the new patched one.

Upgrading a Linux distro shouldn't be taken lightly, it can break so many things. This really shouldn't be considered before just patching just one library file.

I applied his patch which worked well, but I also decided to take some time to learn how to compile WINE also. Just READ, READ, READ up on the process before you try it. You should be proficient with the command line before even attempting it. If there is ANY terminology that you do not understand then get on their forums and ask politely. Understand everything you are doing before you try it. If you have to figure something out, document what you did. In general, document your procedure too as this will make repeatability easier to obtain should they do more crazy stuff like this in the future. This is the best advice I can give if you decide to try to compile it yourself.

My compiled version that I made matched his file perfectly, size, etc. MD5 even matches.
My update -

I've bit the bullet and updated openSuSE 13.2 to Leap 42.1. This opened up Wine 1.9.6 and gave me the 4.1.15-8-default kernel (x64). Overall, I'm very pleased with the in-place update.

But WoW is still 'Connecting...'

I snagged the following output of Wine, for what it's worth...

fixme:win:EnumDisplayDevicesW ((null),0,0x23e1f0,0x00000000), stub!
err:ntdll:NtQueryInformationToken Unhandled Token Information class 28!
fixme:advapi:BuildSecurityDescriptorW ((nil),(nil),1,0x23f598,0,(nil),0xafd4010,0x23f58c,0x23f570) stub!
err:ntdll:NtQueryInformationToken Unhandled Token Information class 28!
fixme:advapi:BuildSecurityDescriptorW ((nil),(nil),1,0x23f598,0,(nil),0xafd4010,0x23f58c,0x23f570) stub!
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0xeb4e4f8): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x23e570,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x23e310,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x23e560,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x23e300,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x23e560,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x23e300,0x00000000), stub!
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:ver:GetCurrentPackageId (0x497e9f8 (nil)): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f588,0x00000000), stub!
fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
fixme:wbemprox:client_security_SetBlanket 0x7dc837c0, 0x166d60, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7dc837c0
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
fixme:wbemprox:enum_class_object_Next timeout not supported
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x456e9f8 (nil)): stub
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:ver:GetCurrentPackageId (0x33e8ac (nil)): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33f588,0x00000000), stub!
fixme:wbemprox:wbem_locator_ConnectServer unsupported flags
fixme:wbemprox:client_security_SetBlanket 0x7daff7c0, 0x1675d8, 10, 0, (null), 3, 3, (nil), 0x00000000
fixme:wbemprox:client_security_Release 0x7daff7c0
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform


There's actually more output with 1.9.6 than there was with 1.8 and 1.7, interestingly enough... anyway, back to the drawing board... :)
Working now.
14.04 + wine 1.9.6 patched + super old kernel

It does seem that the tls change caused the issue, not really related to anything else (kernel, distribution, etc).

== "Connecting..." problem at first
apt-get install winehq-devel
(this brought up 1.9.6 - still didn't work)

downloaded 1.9.6 source, patched file (pastebin, earlier - just 1 .c changed), compiled, and replaced the system's /opt/wine-devel/lib64/wine/secur32.dll.so, with the one I had just compiled - this got rid of "connecting..." problem, but still getting disconnect error.

== issue #1 - disconnect problem (regardless of user/pass)
In the wine downloaded source, make clean, and then apt-get install libgnutls-dev, and make to recompile.
Replaced secur32.dll.so (32 and 64), and it connects just fine now.

If it's still acting up, I'd also try to run directly from wine64 Wow-64.exe; as I had some odd cases pop up using the Battle.net launcher (somehow using my 32bit dll.... or trying to, I removed it)

====
In case the precompiled versions are close enough to be compatible for you:
wine 1.9.6
ubuntu 14.04
Backup your own versions first.. but if it helps someone avoid patching/compiling, great.

32bit version:
https://www.dropbox.com/s/yogsfr775ecl9rf/secur32.dll.so.32?dl=0

Replaces:
/opt/wine-devel/lib/wine/secur32.dll.so
=====
64bit version:
https://www.dropbox.com/s/6jzyfcz8ng4qvw4/secur32.dll.so.64?dl=0

Replaces:
/opt/wine-devel/lib64/wine/secur32.dll.so
I've now gone and tried wine-devel for 1.9.6, replacing the secur32.dll.so for x32 and x64... I've gotten past the 'Connecting...' bit, but am now stuck at Issue #1 (disconnecting). That appears to be an actual recompile of Wine. Cross yer fingers...
I made a slightly better version of the patched function that will only enable LATEST_RECORD_VERSION if the client application specifically disables SP_PROT_SSL3_CLIENT. This seems like it would be less likely to have any adverse effects, since if the client application is requesting no to use SSL, the server it is connecting to probably supports the newer protocol. The old way was probably still safe enough, seeing as though the newer versions of the gnutls library have changed the default behavior though.

Edit: One last change, I shortened the buffer by 32 bytes, it will still hold the maximum size gnutls priority string, and I also changed it so it checks the the application is requesting a TLS connection, and not requesting an SSL connection.

Full function:
http://pastebin.com/RvGxhq0n

schannel_gnutls.c diff:
http://pastebin.com/kZqj9zs2
Linux Mint 17.3, stock 3.x kernel, nvidia drivers

I was stuck on "Connecting.." for a while.

I upgraded to wine 1.9.6 (wine-devel) as suggested, still stuck.

I downloaded Pontudinho's secure32.dll.so. THANKS SO MUCH.

Replacing this file in /opt/wine-devel/lib64/wine got me past the Connecting.. issue.

Again, great community here. Amazed that this was fixed so fast, really grateful for everyone's efforts.
thank you very much, now i can play !

03/25/2016 07:46 PMPosted by Rootsuid
Working now.
14.04 + wine 1.9.6 patched + super old kernel

It does seem that the tls change caused the issue, not really related to anything else (kernel, distribution, etc).

== "Connecting..." problem at first
apt-get install winehq-devel
(this brought up 1.9.6 - still didn't work)

downloaded 1.9.6 source, patched file (pastebin, earlier - just 1 .c changed), compiled, and replaced the system's /opt/wine-devel/lib64/wine/secur32.dll.so, with the one I had just compiled - this got rid of "connecting..." problem, but still getting disconnect error.

== issue #1 - disconnect problem (regardless of user/pass)
In the wine downloaded source, make clean, and then apt-get install libgnutls-dev, and make to recompile.
Replaced secur32.dll.so (32 and 64), and it connects just fine now.

If it's still acting up, I'd also try to run directly from wine64 Wow-64.exe; as I had some odd cases pop up using the Battle.net launcher (somehow using my 32bit dll.... or trying to, I removed it)

====
In case the precompiled versions are close enough to be compatible for you:
wine 1.9.6
ubuntu 14.04
Backup your own versions first.. but if it helps someone avoid patching/compiling, great.

32bit version:
https://www.dropbox.com/s/yogsfr775ecl9rf/secur32.dll.so.32?dl=0

Replaces:
/opt/wine-devel/lib/wine/secur32.dll.so
=====
64bit version:
https://www.dropbox.com/s/6jzyfcz8ng4qvw4/secur32.dll.so.64?dl=0

Replaces:
/opt/wine-devel/lib64/wine/secur32.dll.so
1. wine-1.9.6 ($ wine --version)
2. Linux version 3.19.0-32-generic ($ cat /proc/version)
3. Linux Mint 17.3 Rosa ($ cat /etc/*-release)
4. Issue #2, stuck connecting.
5. Upgraded wine from 1.6 to 1.9. Nothing changed.
32bit version:
https://www.dropbox.com/s/yogsfr775ecl9rf/secur32.dll.so.32?dl=0

Replaces:
/opt/wine-devel/lib/wine/secur32.dll.so
=====
64bit version:
https://www.dropbox.com/s/6jzyfcz8ng4qvw4/secur32.dll.so.64?dl=0

Replaces:
/opt/wine-devel/lib64/wine/secur32.dll.so
This fixed my problem. Thank you!
Hello.

I'm using OpenSUSE 13.1 and the wine 1.9.6 rmp version for 32 bit. I could get over the issue #2 with the @Pontudinho solution. I had compiled my own secur32.dll.so following the @Store patch. Finally, I copied secur32.dll.so to /usr/lib/wine/secur32.dll.so and Wow worked again.

Thanks to all the Linux community and their enthusiasm, and sorry for my English grammar.
Had Ubuntu 14.04, still kind of do, Mint 17.03 (runs nicer)...

1. I nuked Ubuntu on apt-get dist-upgrade 's
2. Started using windows 10, but the launcher got stuck in some endless loop of updates, never enabling play
3. Bypassed this by directly launching Wow-64.exe in Windows 10, worked
4. Installed Mint 17.03 stock, with 4.2 kernels, and with both 1.8.x and the devel versions. Still no change, still "connecting"...

Anyways... this all happened why? To add a useless drop-down box to the login screen??? Can't you just change authentication back for now, and try what ever goofy thing you have planned later after you work the bugs out?

Oh yeah on Window 10 fun land, The Launcher is locked in a never ending update, you can never click "Play".

Join the Conversation

Return to Forum