Battle Stones

Bug Report
My Battle stones wont work on my enchanted broom. They work on other pets. The enchanted broom shows as level 0 when I summon it. No matter what level they are.
Same issue, level 0 when summoned. Tried putting it in a cage and relearning it, no dice.
I have been having the same issue.

    The pet was showing at actual level in my journal but level 0 when targeted
    The pet won't accept a battle stone of any type (Magic, Flawless, Fel-Touched)

The pet does gain xp when you battle with it and the xp gain appears to be normal
As of today (July 22) Kul Tiras (US) 0900, server time, the pet level shows as accurate when targeted.
Yup, yup. I reported this on beta about two weeks ago.

Here's the info I got while messing with it:

http://us.battle.net/wow/en/forum/topic/20745636567?page=1#0

07/08/2016 01:37 AMPosted by Tindomerel
Purchased one of these on a horde alt I copied over and learned it. It's uncommon quality, so I decided to stone it up to rare quality.

Summoned the little guy, right clicked on the stone and tried to left click on the broom to apply it. Nothing happens. The stone doesn't apply at all.

Tried a Flawless Magical Battle-stone. Same thing.

Tried a Pet Treat and a Lesser Pet Treat, as well as both the Fel-Touched and Flawless Battle-training Stones.

Once you right click on any of the above objects, the broom essentially is no longer able to be interacted with or targeted.

Bought a second broom thinking maybe the first one was just bugged. Same thing. Neither one of them can be upgraded.

Bought a Mechanopeep pet on an Alliance character and I can apply all of the above items to it as intended with no problems.

The Brooms can be used as battlepets. They gain levels just fine.They just don't seem to be able to be changed to rare quality on Beta. One thing I did notice is that there's something off about the levels they're showing. If I target them while summoned, they show to be Level 0 on the nameplate. Mousing over the Brooms also says they're Level 0 in the tooltip. In actuality, one of them is level 1, the other level 2. They show as their true level in the pet journal and during a pet battle however.

I'm out of ideas on what the issue could be, nor can I find a workaround to bump my little sweeping guy up to Rare. :(

Join the Conversation

Return to Forum