Darkmoon Faire Achievement Freeze

Technical Support
http://eu.battle.net/forums/en/wow/topic/17613001517

I'm having the same issue reported in the EU thread above. I just started doing Darkmoon achievements and of the 5 or 6 I've completed all but one have caused WoW's CPU usage to spike and the application to hang immediately when the toast notification would pop-up.

Clearing cache did not help. Ran a repair scan and I think it tried to download a small fix, so I guess I'll see how it goes now.

Repair scan did not fix things. Obtained another achievement and the game froze again.

Deleted both Interface and WTF folders and crashes still occur.
This is happening to me as well. 3 achievements, 3 freezes/crashes. I can alt-tab out of the game but I lose my mouse pointer as well. Game does not close until I do a full PC restart.
Same here. Must be a bug. Any suggestions Blizz?
Same as well. The standard achievements completed fine for me. The 41 whack-a-gnoll and flawless turtle ring toss achievements caused crashes for me so far. Probably going to happen for the 25 flying ring achievement too.

I have to force-close the program through task manager after the freeze.
Same. Game crashes instantly upon getting a Darkmoon achievement and I have to restart it (don't have to restart my PC though)
Same here. Tried clearing Cache folder and disabling addons - issue persists.
This has only happened once. Game froze upon earning the Darkmoon Racer Roadhog achievement and had to force close WoW. It didn't freeze when earning other Darkmoon achievements.
Same here, game freezes on every Darkmoon Faire achievement.
At first the achievements caused a great amount of lag, and ended up crashing me after each one. For some reason this was affecting my game, and causing lag periodically. After a crash, (which wasn't the result of an achievement) I had to restart my computer as WoW wasn't letting me switch, or open my task manager. After a successful restart, the Battle.net launcher saw that something was wrong, and ended up being stuck in an endless loop of it wanting to scan for any corrupted files. I looked up some possible fixes, one was to delete the Battle.net folder in programdata, which didnt solve anything. Now I'm stuck with the launcher saying to update, making the game unplayable.
Happening to me as well, and to a guildie. This is clearly something buggy on Blizzard's end.
Happens to me as well, both with and without addons.

I also noticed the super high memory usage of the game when the crashes/freezes happen, but I am able to kill it from task manager.

I'm on windows 8.1, 8GB RAM. Graphical settings to minimum don't prevent it either.
I am experiencing this issue too. Cannot use task manager to quit WoW because WoW covers it up and I cannot click anything. Windows 10.
Still happening. Needs a fix.
+1 This is happening to me as well
Same here.
same here lol

Join the Conversation

Return to Forum