Bug - Mariner's Revenge

Bug Report
Trying to complete the quest "Mariner's Revenge" in the Dread Wastes. Zero target marks are appearing, zero hits are landing, on all four sites. Spraying the thing at random with hundreds of shots didn't work. Leaving the boat and getting in again didn't work. Dropping the quest and picking it up again didn't work. Some have suggested killing Jiao manually to get the thing to reset, but you can't target Jiao outside of the quest. Can't complete the quest, and therefore can't complete the achievement.
Update - I watched to see if someone else would start the quest to see what happened. Even outside the quest I could see that the red reticules were working, so I got in the boat myself and the quest worked.
I'm having the same issue. I can only target the birds. I've dropped the quest and reset it multiple times.
Im having the same issue
I am having the same issue, I made a bug request
Same issue. I have a ticket with support open and am linking this thread.
Same here
Same here
I have been having this issue for the last hour. Any suggestions other than, disabling add ons, re logging, abandoning quest and opening a ticket?
issue is annoying #bump
The Mariner's Revenge quest is not working for me either. The red targeting circles do not appear, and I cannot land a hit to progress the quest. I have tried and had no success with the following in attempts to resolve the issue on my own:
  • Leave the vehicle and re-enter
  • Abandon the quest and start it over.
  • Reload UI.
  • Log out and exit WoW and Battle.net and try all above again.
  • Finally, I watched a video of someone performing this quest to see where the targeting circles are supposed to appear. I aimed at those locations and was still unable to land a hit.

I understand that new Legion content bugs probably have higher priority than most non-current content bugs, but this bug appears that it will halt my progress on several Panderia achievements (e.g. Dread Haste Makes Dread Waste and Loremaster of Pandaria). It would be great if this could get into the roadmap for the next major patch.
Same issue.
any progress with fixing this?
still broken, reticle still not showing up and can't progress chain of quests
Same problem as everyone else. Tried all the suggestions from Blizzard, no cross-hair, still can't complete.
Same issue, have tried everything listed above except opening a bug report so far

Notably, the mob's neutral, not hostile. Maybe that's related?

Edit: release of patch 7.1 seems to have fixed it for me, was able to proceed and complete
quest still broken
Confirmed, quest still broken. No red reticules at all. And patch 7.1 did not solve it for me.
Just tried this quest.... still broken.
Still broken.

Join the Conversation

Return to Forum