Quest circles not showing on minimap

UI and Macro
Having an issue, where im not seeing where to go on the mini map in temrs of objectives

Watching youtube clips alot of quests have blue circles on the minimap, im not seeing any.

I have POI ticked, anything else I can try?
Having the same problem. Actually having to read quests to know where to go.

No highlighted areas on map, no "?" to know where to hand in, or where to go for the 'Speak with ----- at here' quests.

Hoping for a fix soon but in the meantime I'll look at positives like how its preventing me from hurrying through and taking no story in.
This is extremely annoying.
I'm having the same issue, I thought I was having an unusually have time finding stuff since questing in legion. I get the arrow that tells me where to go, then when I get close, I get nothing, until I stumble on the objective and I get a yellow or silver dot. never get the circle that is supposed to be between those two steps.

I only realized it because I was stuck on a quest with no idea where to go as the map told me nothing. Watched a YouTube video and notice this guys minima has circles telling him exactly where to go!

I thought my add-on "Sexymap" was the problem, so I deleted it. Still not working? Do I have to delete the WTF? Really hate setting up all my add-on again...
Make sure that you are tracking quest POI's and that should fix the problem. I also use SexyMap and haven't had a problem once i turned that on.

Now if it would just STAY turned on.....
I'm having the same issue and I've already enabled the track quest POI's option on the map.

It's annoying as hell, tbh.
I was having the same problem but haven't noticed any issues after turning on POI tracking.

On that note though I have noticed the "?" For quest turn ins has been missing sometimes, same deal for the "!" to pick up a quest, almost missed some quests all together because I didn't see the npc.

All this seems to be rather random though as sometimes it works fine.
08/31/2016 11:00 PMPosted by Sinshunt
Make sure that you are tracking quest POI's and that should fix the problem. I also use SexyMap and haven't had a problem once i turned that on.

Now if it would just STAY turned on.....


I can confirm Quest POIs is indeed turned on in the magnifying glass. I DO get the Big blob areas that tell me where to kill or collect stuff, but I DO NOT get the little blue circles that pinpoint exact objects or named mobs. Its getting really frustrating because the map only gets me so close then I'm completely on my own to find the location of stuff the rest of the way. Also I know they should be there because I can watch a youtube video of the same quest and that person has the little blue circles telling him exactly where "Mob Smith" is located. Even when he hasn't respawned yet.

I have already tried deleting the WTF and Cache folders, and logged in with no addons enabled, and Quest POIs still refuses to work 100% with the stock UI.

any other ideas? Blues?
I don't think that's a default feature? I've never noticed these little blue circles?

Are you sure he wasn't using an addon to do that in the video?
09/01/2016 10:15 PMPosted by Bloodrank
I don't think that's a default feature? I've never noticed these little blue circles?

Are you sure he wasn't using an addon to do that in the video?


I've had them before, and I'm pretty sure its not any of my add-ons, I'm really only running a handful of them. You really haven't seen them? Maybe your map is broken too and you didn't notice, We haven't quested in soo long, lol.
https://www.youtube.com/watch?v=h7cYfjzIwDU

This is what I'm talking about, look as his minimap, there white/blue circles. I'm pretty sure this is supposed to be part of the stock UI, I remember having it before.
Yeah they should come up when POI is being tracked I believe. Maybe there is a bug, like I said before I have noticed issues myself.
Same problem here. Definitely used to have the blue circle before - this is a new issue, has nothing to do with addons because i don't use them at all. Tracking POI is on. About to open a ticket - hope it gets fixed. Good luck.
Same problem here, I have tried to the point of reinstalling wow. I am fairly sure it is a bug and its affecting a lot of players.
Same problem here! Anyone get a fix yet? Blue, help!! D:
Bump :(
This needs fixed, somewhat of a annoyance to constantly be zooming the main map just to get a idea of where to go.
Same problem here
Same problem.
Same issues.

Join the Conversation

Return to Forum