Goddess Watch Over You, not working

Quests
This is a quest I just have automatically at 110. When I abandon it, it just comes back. It's a ORDER HALL quest.

Watching a video, it says I'm supposed to turn something into the Archmage at Dalaran, but when I go to him he just has a gray question mark above his head.

Confused myself as to how to complete this. Thoughts?

Thank you
bump.. having the same problem :(
same
I even went back to Val'sharah to make sure i did the chain quest.. i know i started it, but no quests show for me anymore that are supposed to be on the chain quest... bug maybe?
Same, I have the quest but have no idea where the Tears of Elune are. I have literally walked around the entire area searching! Unless I am not doing it right? I get the quest as soon as I go to my class hall but can't go further, has anyone else got past that part?
Well, well I'm not glad to see others are having the same issue, glad to see it's not just me being insane
when i click on it in my quest log, the map just shows Val'sharah, but points no direction in where to go... oh well :'(
When I ended up abandoning it, it just disappeared. I have no idea how to get it back, and no idea how to solve it. Any information would be awesome.
I think you can get the quest back in the order hall.

I just got the Tear by questing in Val'sharah. I don't remember which chapter it was, but one of the quest chains gave me the item to turn in.

Like everyone else, I could not figure this out and just started doing every quest I could find hoping to get the Tear.
I made a ticket for this in game. Any info I get I will pass here.
Yeah I am stuck as well on my shaman.
Got ticket response back, just saying they're overwhelmed by tickets at the moment, and most answers can be found on wowhead.
Will have to just ignore this quest for now
Requires the Achievement: That's Val'sharah Folks. You get the tear at the end.
yeah same problem any info on how to complete it?
^ yep..wowhead didnt really help much at all with this
Yeah same issue here. I completed it, but couldn't turn it in anywhere. So eventually I abandoned the quest to start over-bad idea because now it's complete but I don't have the tears anymore and cant start over. So I guess just hang tight and don't attempt to restart!
Well I haven't confirmed this yet but someone left this comment:
Requires the Achievement: That's Val'sharah Folks. You get the tear at the end.

I will try it eventually and see what happens.
09/04/2016 03:18 PMPosted by Necranesce
Requires the Achievement: That's Val'sharah Folks. You get the tear at the end.

wait what? is it really that easy??
Confirmed. The quest starts pre maturely. go to your order hall and start the Val quest chain from your board, play through and it will complete.
Just tried it and it worked ... I had to get the achievement first [That's Val'Sharah Folks] then it ''unbugs'' the quest and you get to continue the quest.

Join the Conversation

Return to Forum