Wanding 101 quest is bugged..

Bug Report
1 2 3 5 Next
Nevermind, This was an user error issue.
What ended up being the fix for you because everyone in my area including me is having a problem with it..?
Having the same problem. i cant hit any of the dummies with my wand.
does anyone have a solution for this?
same having a problem with this quest.

Even when you attack students, the instructor yells ' I said no point blank shots'
I'm also having a problem with this quest. Tried logging out, reloading ui, and even restarting the game. Nothing worked.
yeah to hell with this quest, I cannot get it to work right now on my warrior, I walk right up to them, then walk way the hell back without changing the direction I am facing and shoot the wand and they dont spin or anything even tho the wand bullet is passing right through them. I have shot at them all so it's not some order problem.
I am having the same problem and I have seen people in my server trying to repeatedly hit the same target so I am assuming that they are as well. The patch may have delete something or that blizzard has changed something during the patch.
Had the same problem when I leveled my Paladin when legion dropped but that was fix by abandoning the mission, reloading the game, and trying again. It worked after that.
This time I attempted the same strategy and it did not have the same results.
Yeah I tried that too and no luck
Not working for me either
[EDIT]It works now for me.

Same problem here, this morning i got 6/10 then it stopped working, since then have abandoned the quest and re taken it and it never works
Same problem here!
It's not working
Having same problem. I dont even get the quotes the NPC's give when you blast them.
same problem cant progress.
Quest still bugged, submitted a ticket and tweeted the ticket # to blizzard. Hopefully this will get their attention.
It's bugged, just send in a report and hope for an update soon.
Same here, still bugged for me
I got it to work a few seconds ago, I had to logout and dismiss it then repick it up and wait about a minute and it started working. Seems like patience is the key grasshopper. As most of us loremasters know, the quests in this game aren't exactly bug free.
yep bugged, cant even quest now

Join the Conversation

Return to Forum