Armory App

Bug Report
2ND REPORT

I have the WoW Armory app on my iPhone 6+ (iOS 10.0.2), and cannot log into it. I enter my username, password, and authentication code. The next screen that comes up is missing two icons. There is also a loading icon in the center of the screen that shows up, blinks out, and reapears. This recycles indefinitely.

I tried deleting the app several times for varying amount of time, including days. I've shut off my phone between reloads for a few minutes or more, and even tried backing up my phone before reinstalling. Yet I continue to get the same issues.

Is there a way to fix this issue on my end, or is there something on your end which needs to be done?
I figured out the problem, and discovered another.

The issue described above began to occur after I changed my battle.net account email address. I did that in an attempt to link my account to Facebook, which I'm still unsuccessful in doing. Even entering the new email in the armory app, I still had the problem - but only on the app - not any Blizzard game or the companion app.

Once I switched the account email back to the old one, the armory app worked again.

So my new question is, why didn't the new email take on the armory app?

That is on Blizzard's end.
Changing my email back worked for me too, same issue. But now I don't feel my account is nearly as secure.
Oh well maybe they will fix it in the next update

Join the Conversation

Return to Forum