Huge loading screen wait time as of 7.1

Technical Support
Prev 1 104 105 106 189 Next
so i first posted here 10 hours ago.

that was roughly when my problems with this began.

this time yesterday the game was running perfectly, but today i started getting the long load screen and required force restart that go's with it.

this has progressively gotten worse through the day.
I have done everything suggested in this thread and nothing is working.

game is borderline unplayable right now.
this really sucks. it's unbearable and not worth playing. we should get a free month or two for putting up with this crap. i'm sick of doing tickets and them telling to clear my cache. it's blizzard's end to why this is happening.
Happy Thanksgiving everyone!
Where's our FIXINS'!?

On a serious note, seriously, where's our fix or hell even an ounce of communication?
Logging OFF! Can't take it anymore. Game is unplayable
11/24/2016 06:16 AMPosted by Smokeski
This might explain why we are having problems. The old engine cannot handle the game any longer. The following was posted on MMO Champion this morning. I have a feeling there is no near term fix for what is happening:

Blizzard Entertainment is seeking an experienced engine engineer to work on a robust first-person engine for an unannounced project. The ideal applicant has demonstrated ability to lead a team of engineers to success, has a vision for how a scalable, performant and technically excellent engine should be built, and has a passion for adopting state of the art rendering technology to implement visually stunning games.
Wellll, are we really going to have to wait for them to hire someone and build an new engine before this problem is fixed? At this point it almost seems like it...
i've resigned to permanently keeping my game in fullscreen windowed mode with task manager always open so i can "quickly" shut the game down whenever the bullsh*t inevitably happens.
11/24/2016 06:16 AMPosted by Smokeski
This might explain why we are having problems. The old engine cannot handle the game any longer. The following was posted on MMO Champion this morning. I have a feeling there is no near term fix for what is happening:

Blizzard Entertainment is seeking an experienced engine engineer to work on a robust first-person engine for an unannounced project. The ideal applicant has demonstrated ability to lead a team of engineers to success, has a vision for how a scalable, performant and technically excellent engine should be built, and has a passion for adopting state of the art rendering technology to implement visually stunning games.


Loading screen issues are happening in 'Overwatch' as well.
http://us.battle.net/forums/en/overwatch/topic/20749865782
11/24/2016 06:05 AMPosted by Insanebrit
So yes, I had stopped playing.

Just decided to see if anything was different on my Laptop, and lo and behold, it's a Holiday miracle.

My laptop is a MacBook Pro with 16GB of memory. It has really quick loading into Garrison, Dalaran etc. My iMac has 4GB of memory and had the loading time problems.

It Must be something to do with memory. Something about having to swap in and out pages of memory or something.


I have this problem with 16 GB of RAM.
11/24/2016 08:02 AMPosted by Elkhorn
11/24/2016 06:16 AMPosted by Smokeski
This might explain why we are having problems. The old engine cannot handle the game any longer. The following was posted on MMO Champion this morning. I have a feeling there is no near term fix for what is happening:

Blizzard Entertainment is seeking an experienced engine engineer to work on a robust first-person engine for an unannounced project. The ideal applicant has demonstrated ability to lead a team of engineers to success, has a vision for how a scalable, performant and technically excellent engine should be built, and has a passion for adopting state of the art rendering technology to implement visually stunning games.


Loading screen issues are happening in 'Overwatch' as well.
http://us.battle.net/forums/en/overwatch/topic/20749865782


This can't be a coincidence. Someone at Blizzard is royally !@#$ing up and they refuse to nut up and admit it.
It has come to the point that the only hope I have is that more and more people have this problem so they can solve it as quickly as possible
Well, happy Thanksgiving everyone.

Fingers crossed for a fix soon.
I'm so tired of having to force quit just to get things to load... any fixes yet?
11/24/2016 07:56 AMPosted by Brahmina
11/24/2016 06:16 AMPosted by Smokeski
This might explain why we are having problems. The old engine cannot handle the game any longer. The following was posted on MMO Champion this morning. I have a feeling there is no near term fix for what is happening:

Blizzard Entertainment is seeking an experienced engine engineer to work on a robust first-person engine for an unannounced project. The ideal applicant has demonstrated ability to lead a team of engineers to success, has a vision for how a scalable, performant and technically excellent engine should be built, and has a passion for adopting state of the art rendering technology to implement visually stunning games.
Wellll, are we really going to have to wait for them to hire someone and build an new engine before this problem is fixed? At this point it almost seems like it...


But they want someone to build a FIRST person engine for a NEW game, not a 3rd person game (like WoW). ;)
11/24/2016 11:47 AMPosted by Demimonde

But they want someone to build a FIRST person engine for a NEW game, not a 3rd person game (like WoW). ;)
World of Duty: Azerothian Warcraft
So just thought I'd throw my hat in this ring. I've been watching this thread for a good while and I did try the suggestions earlier in the thread several times, but nothing has really helped.

Running Mac. No load issues before this patch. Now I have 5m to 30m load times - but usually only super long if I am loading into Dalaran (but not out of it).

For some class halls it's not as bad. The Rogue can run to his after loading Dal, do his thing, and run out without an issue. The DH often has a load wall of hearthing to Dal, then some class hall loading, then another massive Dal load. This combined with the fact that if I am going TO Dal, I have to Force Quit the game about 90% of the time. However it seems if I quit too early, it doesn't load my destination. So essentially it is now (for DH), Hearth to Dal > Wait Some > Force Quit > Reload (Huge) > Load Class Hall... turn in quest > Port to Dal > Wait Some > Force Quit > Reload (Huge). The Paladin and Mage are the same way.

If I am out in the Broken Shore, I fly to Dal. I don't even Hearth. Sometimes I land and it hasn't loaded a higher rez version of the city - and I stumble around looking for doors through crazy low geometry for about 5 to 10 mins.

At first I thought "it" (Huge Dal load that inevitably needs to be Force Quit and reloaded) was just when going to Dal from a class hall or Hearthstone - but using a Mage port to Dal from Org did it too.

It get's frustrating to play at times.

I know you're aware of the situation, and I thought confirming that it seemed to be Dal related might help a smidge.
Guess I'm not the only one. Happy Thanksgiving Blizz!!!

"Go on holiday, they said. Nothing will happen, they said"
Hey BLIZZARD! Why don't ya' wankers get off yer sodding asses and COMMUNICATE with your player base!? You know what that is, right? C-O-M-M-U-N-I-CA-T-I-O-N. There, I spelled it out for you. Simple enough for you? This problem has been going on for how long now, eh? Would you like to venture a guess? No? Why not? Oh. Because you KNOW. You're working on a solution, right? I'm sorry, what was that? Couldn't hear you. What is the solution? Nope. Still couldn't hear you. Oh. Because, you haven't TOLD us! Nothing. No more, "We're aware of the problem and......". A person is aware if they have hemorrhoids. They KNOW it's a problem. What they need to know is if their is a FIX for it! Well? Blizzard? Helllloooooooo. You listening out there? Can't tell. We've got NO answers. Imagine that. Who is coding your game? Where are the programmers that worked on the last patch? Have you bothered to tell them to get on it and figure out what they royally screwed? HAVE you? Notice all the capitalized words? Thought it might draw your attention and get you to listen to your PAYING, PLAYER BASE! And, oh here's an idea.....COMMUNICATE AND TELL US JUST WHAT EXACTLY YOU WANKERS HAVE BEEN DOING TO FIX THE PROBLEM! Thank you and, have a pleasant day.

P.S. My loading screen to Dalaran has been frozen for over 20 MINUTES!
P.S.S. Wankers
Load screen Alt + F4, can we get a comment here please. What's the ETA on resolving this problem? I was hopeful that the small fixes downloaded today would have addressed it but sadly no.
11/11/2016 06:28 PMPosted by Glaxigrav

Our Tech Support team is still following this issue, and we'll be sure to update you as soon as we hear more. Thank you!

Two weeks since this update. Surely you have something more by now?
update day 2.

this issue started for me yesterday.

woke up this morning, and its still happening.

i have changed NOTHING in the past 48 hours, this issue is on blizzards end.

game is virtually unplayable when i have to do a hard restart at every load screen.

giving it one more day then im finding a new game, i NEVER threaten to cancel my sub or anything like that, but this is beyond frustrating and unless im compensated for my time, i wont continue to purchase this game.

Join the Conversation

Return to Forum