Huge loading screen wait time as of 7.1

Technical Support
Prev 1 82 83 84 189 Next
I'm having this issue as well. I don't know if it's been mentioned or not, but I seem to only have it happen upon hearthing to Dalaran with the Dalaran hearthstone. If I return to there from any order hall it loads just fine.
Set your hearth to Shal'aran and fly to Dalaran. Way faster than actually loading into Dalaran.
Well, I thought it fixed itself for me after I had a few days with no problems, but now the problem is back again, and a few of my friends have also noticed it happening to them. I don't imagine a fix anytime soon. I hope they plan to compensate us for something.
This problem has become even worse this week with the Arena weekly quest. I've had to force quit the game after every arena battle - no matter where I am - because the post Arena loading screen will never go away.

It's weird because even though I'm on a loading screen I can somehow hear things as if the loading has finished (music changes from loading screen to city music, I could hear the sound of it telling me the queue for my next arena was up), but my screen never goes off the loading screen.
11/18/2016 12:26 AMPosted by Vhyle
I'm having this issue as well. I don't know if it's been mentioned or not, but I seem to only have it happen upon hearthing to Dalaran with the Dalaran hearthstone. If I return to there from any order hall it loads just fine.

Unfortunately not the case here; Dalaran freezes 100% of the time when coming from class halls on multiple characters for me. (In addition to Dalaran hearth.)
Trying to do Pet Tamer battles in WoD and MoP is so frustrating, loading slowly into the game.... hearth to Garrison, restart, load slowly into the game... hearth to Dalaran, restart, load slowly into the game... port to MoP, restart, load slowly into the game.... talk about horse !@#$?!??!! this takes the cake right here.

Get summoned anywhere, you best make sure the people know you may need to restart the game and will be back... it is pointless trying to do LFR as you will end up being vote kicked before you can load in usually.

Thanks Blizzard, this really giving me some great memories to remember Legion with.
My account and my wife's account on separate PCs are also experiencing extremely long load times.
i have noticed Dalaran was never fully loaded before in 7.0. Now with the long loading times in 7.1 everything in Dalaran is loaded. Please don't tell me this is a trade off. Because every other city is fine.
Checking in on the load screen issues.. started for me last night. load screens are taking up to 5 min when I hearth to dal and i randomly drop to 8-10 fps anywhere in dal.

I have a gtx1080 i76700 and an 850 EVO SSD so the pc isnt the issue :"(
After I got curious I started a timer. I hearthed to my garrison at 08:47 Central in an attempt to pick potion flowers before the dailies reset. As of this moment it is 09:05 and I am still on the loading screen.

Fix your sh*t damnit
It

11/18/2016 07:07 AMPosted by Salani
After I got curious I started a timer. I hearthed to my garrison at 08:47 Central in an attempt to pick potion flowers before the dailies reset. As of this moment it is 09:05 and I am still on the loading screen.

Fix your sh*t damnit


It never did load. I shut it off at 09:12. If I can't play, why play? Cancelled. Civ VI is more fun right now anyway.
Did some more testing to make sure my changes to the settings weren't a fluke. I've played a bunch more in this mode (see the original post below) and it still seems to have fixed the problem for me. Keep in mind it's not permanent, as I no longer ever tab out (annoying not to be able to do that). I have a laptop that I keep nearby for when I want to look something up, but blizz is not off the hook for fixing this!

To sum it up: For my system (windows 10) I'm back to normal operation with all Windows Notifications turned off (see below on how to do this) AND never I tab out. I hope this helps at least some of you poor souls out there.

11/17/2016 08:04 AMPosted by Phlogiston
The following has fixed it (1 day so far) for me. The two things I did (I run windows 10, so I can't say if this will provide relief for other versions):

1) Change the windows notifications settings to OFF. You get to this via Settings->Notifications&Actions. You can also just type "notifications" in the search area (the "Ask me anything" feature that most of you will have at the bottom left of your screen) to bring up the panel. For good measure I also turned off the "Get tips, tricks, and suggestions as you use Windows". Haven't tested if this actually matters - I don't need it so I'll just leave it turned off.

2) I no longer tab out (this frequently causes all kinds screen freeze/black screen problems).

Note that my main playing mode is PvP and world quests. I rarely run PvE instances, so I don't yet know if this fix applies to those. Maybe someone could try this out on dungeons and report back here. Cheers.
Whew. I remember trying to load into this thread weeks ago. Finally got past the loading screen.

Update is this issue is unacceptable.
Horde random battleground queues are brutal so I want to do mercenary mode. The NPC is in Dalaran underbelly and every time a bg ends I go back to the Dalaran loading screen. And of course it freezes and I have to force quit the game. Every time. I don't know if the ashran npcs are still there but that would still be running through hoops and I'd have to hearth back to dalaran anyway.

You are making me UNABLE to play. I can't believe this hasn't been fixed yet
I think I'm going to give Civ VI a shot this weekend instead of WoW as well. I'm afraid to try instances or BGs with friends because I have no way of knowing if I'll ever load into an instance.

Real shame to. Legion is so much fun, but I basically can't play anymore.
How is this still not being addressed? It's the worst for me when porting to Dal. 7 minute wait! Everything else is like 5 minutes. So annoying.
11/18/2016 09:07 AMPosted by Schaller
I'm afraid to try instances or BGs with friends because I have no way of knowing if I'll ever load into an instance.

Real shame to. Legion is so much fun, but I basically can't play anymore.

This!!!
Lets face it, blizzard never really cared that much about their community anyways. Saying !@#$ like they will look into it, or they are trying. I doubt its honestly that hard to back track and figure out what the hell caused all these increased loading times since the patch. This problem probably isnt really even being looked into, hence why they wont give us any answer. It will probably be another month before anything is really truly fixed, maybe even longer. IF they even manage to fix it, all the players that got trashed by this, including myself.. Probably wont get anything out of it, like a free month or something because they do NOT care one bit.
Plenty of responses here, I'll just through in my data.

Fresh reinstall of client, running on defualt settings (and actual video settings reduced to the lowest possible), and no active add-ons in the folder. Still experience an approx 4-5 minute load screen time* when hearthing to Dalaran. When the load finishes (the bar reachs 100%), the screen remains on a full load bar (with dalaran audio and audible character interactions / queue pops) and I am unable to interface at all, requiring a client force quit and restart. Worth noting that while running both the client and the windows host service (just for the client) run at approx. 5gb of ram usage, which strains my old machine quiet a bit.

Machine:
Windows Vista 64-bit SP3.
Intel Core 2 E8500.
8gb DDR2 Ram.
GTX550 Ti (overclocked by approx. 30%)

Join the Conversation

Return to Forum