Workaround to greyed out action bar issue.

Hunter
For anyone who has had the greyed out action bar issue on your hunter I found out that it may be related to certain pets. Apparently any pets that have the ability to stealth, when they go into stealth it causes a bug that is causing your action bars to grey out as if on cool down. If you change pets in go to one that doesn't stealth, the skills reappear off cool down and the issue should not return. Have tested on my wife's hunter with a non stealth pet and has not had bars grey out on her in 5 hours. Possibly stealth related issue.
What a lousy patch.
Thanks, I will try that. Also, my call pet button doesn't work. I have to go into my spellbook and manually click it. It's hard to find the right pet because there's no pics, just whistles with title of "call pet 1", etc.
This was bugging the crap out of me last night I wrote it off as a Domino's bug/new patch.
10/27/2016 10:37 AMPosted by Akheela
For anyone who has had the greyed out action bar issue on your hunter I found out that it may be related to certain pets. Apparently any pets that have the ability to stealth, when they go into stealth it causes a bug that is causing your action bars to grey out as if on cool down. If you change pets in go to one that doesn't stealth, the skills reappear off cool down and the issue should not return. Have tested on my wife's hunter with a non stealth pet and has not had bars grey out on her in 5 hours. Possibly stealth related issue.


Is it just with pets who have it or when you actually use it? I main with spirit pets a lot and they all have stealth but I only use it in Ds to skip trash. I guess I can test this later for myself..now that I think about it. Thank you for finding this out and letting us know tho!
From what I've seen it's only when they use it, like when you log in it takes a couple minutes or seconds for the pet to put itself in stealth, and then you lose the bars to the grey out. Or when you land from a flight paths the same thing, as well as zoning into new zones after a load screen.
The problem with just disabling the skill on your pet is I have seen reports from other Hunters that after logging out and logging back in their skills that they had set up are being reset so you would have to disable the stealth ability every time you login if that is happening to you.
The problem with this workaround is that if you want that 20% damage bonus for the opener -- you lose that if you choose a pet with no stealth. Not a viable alternative for me.
So the alternative that you would prefer to choose is the one where as soon as it stealths you lose your bars and can't tell whether or not the ability is available for use or on cool down therefore disrupting your rotation and damaging your DPS anyways?
Now if it would only get my pet to unstealth. I switched back to BM for some grinding last night and watch as Hati was mashing stuff while my pet slowly limped towards the mobs....it looked like it was crawling in stealth. Mind you this is the spirit moose so it doesn't have stealth.

Blizz screwed the pooch on this one.
10/27/2016 11:50 AMPosted by Hemroid
This was bugging the crap out of me last night I wrote it off as a Domino's bug/new patch.


Me too. It happened to me when I dismissed my tiger who stealths and took out my tank pet (Isle of Giants dinosaur) who does not stealth.

Happened to me during withered training and when it was over and I ported out my bar was fine.
It does seem to be a little better today. Was able to take flights without the issue. The only time it occurred was when using the Dalaran hearthstone --- but far fewer occurrences of the problem today -- no issues in dungeons whatsoever.
So here's the workaround, at least for me it DOES fix the problem.

If you're using a pet with stealth or prowl talent:
1) Remove the stealth/prowl button from the pet bar
2) Dismiss the pet
3) Call it back

You may need to rezone to Trueshot or some other zone, or just do a soft log, but this worked for me. It seems that the prowl ability button is causing all the trouble. You can still toggle the ability by bringing up your spellbook>pet tab, but for now it's necessary to remove it from the action bar. I'm using my cat with prowl ON, but the button isn't on the action bar, and everything is working fine.

Okay Blizzard, we know what the problem is. Please fix it.
I don't think it's a Prowl button on the task bar issue. I have that button on my task bar now and it's work ok for now, as long as I don't port to Dalaran.

What worked for me yesterday was the following:

1. Dismiss pet
2. Relog
3. Call pet back.

Seems like there's quite a few workaround -- but the bottom line is that we just need it fixed.
Thanks for this was wondering why it was doing that.

Guess I will disable stealth on my spirit beast until this is fixed.l as it was also effecting my weak autos addon that I use as my HUD for when abilities are good to be used.

This patch has been a disaster.
10/27/2016 03:43 PMPosted by Gwynevaere
I don't think it's a Prowl button on the task bar issue. I have that button on my task bar now and it's work ok for now, as long as I don't port to Dalaran.

What worked for me yesterday was the following:

1. Dismiss pet
2. Relog
3. Call pet back.

Seems like there's quite a few workaround -- but the bottom line is that we just need it fixed.


well wadaya know... I just hearthed to Dal and buttons were dark. Used your 1,2,3 and back to normal again.
To Leetch, the spirit moose is a spirit Beast and therefore has Spirit walk, which is stealth for spirit beasts. You will find it in your spell book where your pets abilities are.
Akheela -- the problem with the 1,2,3 was that I had to do that about 20x a day or more lol. Talk about annoying? omg ;)
I can imagine. I main a druid, but i spent the past 2 days researching this for my wife who mains a hunter.

Join the Conversation

Return to Forum