for those still getting slow load screens

General Discussion
1 2 3 7 Next
Have you seen this fix yet?

https://eu.battle.net/forums/en/wow/topic/17614664090

basically, here's the post:

Here's my Christmas gift to you AD

/console worldPreloadNonCritical 0

Run that command once and then /reload to save it. No more getting stuck at 70% on the loading screen. Took my 7 year old desktop 19 seconds to load Dalaran


this has cut my load screens down tremendously. that and a new USB SSD and I load lightning fast now.

my apologies if this is has been coverd, but haven't seen it posted here since I got back from vacation.
Just plugged it in and so far, every load screen has been significantly faster. I'd like to see more peoples' input.
I'll try it when I get home from work
I have also seen a significant change in my screen load times. First time loading into Dalaran take about 30sec(was 2 minutes).
posting here so i can easily find it later when i get off work to try it out.
I was amazed it worked as well. Keep waiting for some kind of consequences (whatever they might be heh).
Posting here to save this for later. Will try it and edit my post with results when I get home from work and can fire up WoW.

I tried something a while back that helped a little, but it only shaved a few seconds off an almost 3-minute load screen for Dalaran. If this gets the load time down to 19 seconds, I'll be happy.

edit: Holy !@#$, it worked. I just jumped from Dal to Skyhold in about 4 seconds. Nice!
This is neat.
Bookmarking this for later. Will try it and edit my post with results when I get some time to fire up WoW.

I tried something a while back that helped a little, but it only shaved a few seconds off an almost 3-minute load screen for Dalaran. If this gets the load time down to 19 seconds, I'll be happy.


I did it on my laptop as well (with standard HDD) and it was just around 12 sec to load dalaran. not a powerful comp either, low end student HP I got for $229 new.
For those who are always leary about doing stuff that isn't "official" - the solution is/was already proposed by Blizz here: https://us.battle.net/forums/en/wow/topic/20749718759?page=158 i.e. the EU forums are just spreading the good word.
01/05/2017 08:09 AMPosted by Stoutfoot
For those who are always leary about doing stuff that isn't "official" - the solution is/was already proposed by Blizz here: https://us.battle.net/forums/en/wow/topic/20749718759?page=158 i.e. the EU forums are just spreading the good word.
Yowza, buried on page 158. Not surprised so few saw this. Props to the OP.
Edit; Maybe it's just a mind trick, but I feel like everything is loading/running much smoother. Not a huge deal but if anyone can chime in on that, that'd be swell.
01/05/2017 08:04 AMPosted by Nemestres
posting here so i can easily find it later when i get off work to try it out.


Ditto, thank goodness.
ill have to try it
Anyone online, check your appearances. The helm tab is showing all my boots and the ones I havent collected instead of my helms. Anyone else?
01/05/2017 08:24 AMPosted by Selenn
Anyone online, check your appearances. The helm tab is showing all my boots and the ones I havent collected instead of my helms. Anyone else?
Helm tab is all good here, perhaps it's an addon issue?
01/05/2017 07:59 AMPosted by Mercelida
I'll try it when I get home from work
Nice.
I'd encourage people to load Dal 3-4 times and TIME IT ...

..THEN...

use this command. And time it again.

Compare.

This way, you can know for sure if and how much it's helping. :^)
01/05/2017 08:29 AMPosted by Cozzene
01/05/2017 08:24 AMPosted by Selenn
Anyone online, check your appearances. The helm tab is showing all my boots and the ones I havent collected instead of my helms. Anyone else?
Helm tab is all good here, perhaps it's an addon issue?


Would this code mess with addons? other than possibly skada, nothing has caused this before. Only recently got skada, gonna check it.

E) Ah nope, a simple /reload fixed it. Weird.

Join the Conversation

Return to Forum