Wow51900319 solution?

Technical Support
Ok so I like many other players have had that constant DC issue or really high world latency that makes the game unresponsive or unplayable. I have gone through all the trouble shooting in the forums and I have also done alot of work with my internet provider. Changing wires upgrading things and etc. Nothing worked. Has been a problem I have struggled with for a long time.

So I started messing around with my wow settings yesterday because it was my day off while being plagued with disconnections and unplayable latency.

I changed my max background fps to 15 fps and changed my max foreground fps to 90 from 100. Since I have done this I have not had one bit of lag or a disconnect and we are going on nearly 3 days now. Just something I Wanted to share with the blizzard community. Its above my pay grade to know why this worked or how it fixed anything, but I know nothing in the troubleshooting pages was helping for very long or fixing it. I was nearing the point of unsubscribing out of flustration.
I just did this and it did nothing for me still discconect
Hey there Lrntwohammer!

An unusual issue that has surfaced recently involves the most up to date Nvidia drivers. If you happen to be using version 378.49, rolling back to an earlier version may help. This is being discussed in this thread.

Beyond that, try out the Standard Troubleshooting too. :)
I don't need to try anything. My post was about what I did to fix my problem
01/26/2017 06:51 PMPosted by Lrntwohammer
I don't need to try anything. My post was about what I did to fix my problem


Shows how well support read posts LMAO!
01/27/2017 04:17 AMPosted by Nightagent
01/26/2017 06:51 PMPosted by Lrntwohammer
I don't need to try anything. My post was about what I did to fix my problem


Shows how well support read posts LMAO!


LOL Holy crap!!!! Are they robots?

Join the Conversation

Return to Forum