Problem with windowing on second display

Mac Technical Support
I have a 27" HP2711x display hooked up to my Macbook Pro using the Thunder port thingy. It is recognized properly by the mac and the WoW system settings. Prior to 7.2, I had no problems with full screen at full resolution. Now, when I use full screen, the game window is moved about 1/3 up the screen and the top is accessible. If I reset to recommended settings, it goes back to windowed mode and moves the window to the mac screen, even though the HP 2711x display is chosen in the game's system settings as the monitor to use. The only way I can play on almost-full screen is to drag the game window from the mac screen to the HP display, and use the grow handle at the bottom right to resize it. When I exit the game, and re-open it, the window reappears on the small screen again, and has to be moved and resized. Also, while the terrain, NPCs and scenery textures are normal resolution, my character and other players are so low res as to appear 8-bit. And.. I've dumped cache and wtf... nixed addons, etc...
Same thing is happening to me also. Was fine running on second display but after patch theres a black bar, 2 or 3 inches high at the bottom of my screen the game sits on, cutting off the top of the game.
Same problem here.
I just noticed that the problem goes away if I use any other resolution setting other than max resolution. 1920 x1080 (widescreen) is my max resolution and the problem occurs when at this setting only.
Same exact issue. I changed the resolution after testing a few other things, but now I can't it WoW to run on my secondary monitor, it just stays on the MAC screen. Only thing is, changing the resolution makes it look horrible, so hopefully they address that issue sooner than later!
Having the same exact issue today along with graphic became completely blurry.
We're having mac issues also. The Battlenet window comes up fine, but when WOW opens, it's loading with the bottom half of the window running off the screen. Can't move the window or adjust it's size to get to any of the buttons or controls there. It worked before the patch broke it.
Same here!
http://imgur.com/a/7BjXy
Kinda fixed this temporarily...

1.) Disconnect your second display and start WoW on the main display.
2.) Change the game window mode to windowed.
3.) Re-connect your second display & drag the game window over.
4.) Change settings back to fullscreen
*note (I did not select the second display in the settings, it is still set as my MBP's display)

tip:
also change render settings to 100%. so things look good and then adjust your other settings so. (UI, graphics, cursor size, etc)
03/29/2017 01:51 AMPosted by Illilililli
Kinda fixed this temporarily...


Yep this works. Until you restart the game.
I'm having the same problem as well now, only my setup is a 23.5" Dell monitor (which I use as my main) and a 27" iMac.

http://tinyurl.com/screenissue
03/29/2017 02:14 AMPosted by Fawanu
03/29/2017 01:51 AMPosted by Illilililli
Kinda fixed this temporarily...


Yep this works. Until you restart the game.


Unfortunately, yes.
Same issue with a macbook pro and apple thunderbolt monitor. I tried resetting the UI by renaming Cache, Interface and WTF to CacheOld, InterfaceOld and WTFOld and letting the game re-build them. It didn't help.
Unplugged one of our monitors and ran everything on one, no more problem. So our issue was something to do with the new update not working well with dual-screen mac setup.
Yeah, I've been having the issue where the top of the screen is a black bar when I load WoW on the monitor connected to my MacBook Air. It was perfectly fine in 7.1.5. I've since tried to a) disable addons b) rename the folders as suggested in the support artifact for UI issues. Neither of them work for me.

Unfortunately, because the screen basically is moved down the bottom is cut off so I can't adjust the system settings. I figured out the 4 steps mentioned above which does temporarily fix things, but as soon as you exit the game and launch it again, you'll have the same issue.

I think until this is fixed, the only real thing to do is set your display to windowed before you log out and then change it once you log in. That might work okay. I just forget.
I'm with the same problem. Yesterday i solved it repairing the game, but today, it doesn't worked. I'd tried all those steps mentioned above and nothing worked too.
Are any of you guys having this problem still on El Capitan?

I first saw this glitch on the 7.2 PTR client when I wanted to do the Dalaran brawl. I wrote it off as some kind of temporary problem and I'm mad that I didn't report it because once 7.2 went live I now see it's a definite change.

Apparently, they removed Metal as an option for ElCap users, and I'm suspicious that in removing that they somehow broke the OpenGL viewport for external monitors.

If I start WoW on my primary (laptop) monitor, it works/looks fine. But if I choose my external monitor in the Graphics options, it shows up about 300 pixels higher than the actual bottom of the screen (cutting off the top 1/4). This is for both Fullscreen and Windowed (Fullscreen).

Changing to Windowed I can of course drag it so it's not offscreen, but the aspect ratio of the Windowed mode WoW matches the 4:3 of my primary display and will not fit my 16:9 external monitor. So I end up with pillarboxing and accidentally clicking outside the window or moving the window.
I'm on El Cap. I stopped using Metal a while back when I was having very long loading screens. Switching to OpenGL fixed it.

I'm now getting a message that El Cap is now unsupported every time I log in.

To fix the aspect ratio problem, once you get it windowed on your external display, logout and then log back in. You can then change it to your correct resolution and switch to fullscreen. Just make sure to switch to windowed before you log out after you're done playing.
Same problem here. When I mess around with various resolution settings and random switching between windowed and fullscreen sometimes I can fix it. Then I try the same exact thing and it only makes it worse.

Join the Conversation

Return to Forum