Problem with windowing on second display

Mac Technical Support
Amazing... almost a week since patch day and still no response at all. How utterly disappointing. :(
04/03/2017 02:26 AMPosted by Mikeyrat
Amazing... almost a week since patch day and still no response at all. How utterly disappointing. :(


I agree. I have been patient and kept thinking they would at least respond with a workaround or ETA, but that hasn't happened.
Hello all,

Thank you all for reporting this. Sorry for the delayed reply. We have been investigating that is causing WoW to display like this one second monitor. I do not have an ETA just yet when a fix will be out. Thank you all for your patience while we work on this.
04/03/2017 11:18 AMPosted by Eloemaz
Hello all,

Thank you all for reporting this. Sorry for the delayed reply. We have been investigating that is causing WoW to display like this one second monitor. I do not have an ETA just yet when a fix will be out. Thank you all for your patience while we work on this.


Thank you for at least saying you heard the concern and will be addressing. I will wait patiently for you guys to do your thing. Looking forward to being able to experience 7.2 with better resolution, less FPS issues and my secondary monitor.
Hi guys,
This is a problem in Mission Control (yes its your Mac). Go to System Preferences => Mission Control => Uncheck Displays have seperate Spaces => Reboot.
04/04/2017 06:35 AMPosted by Rockadee
Hi guys,
This is a problem in Mission Control (yes its your Mac). Go to System Preferences => Mission Control => Uncheck Displays have seperate Spaces => Reboot.


Not sure about anyone else, but by doing this it doesn't solve the issue. It actually makes things a bit worse and I am unable to have my other screens in view as I am playing WoW. When I maximum my MB screen, my other screens go black.
Mine has worked great since day 1. The Mac Update didn't do anyone any favors. Mission Control is where you can really set your graphic outputs.

My mission control has everything checked but Group Windows by application and Dashboard should be set As Space.

I'm on Graphics Quality 2 (recommended) with 1440x900 wide resolution. Render Scale is 100%, max foreground FPS 100, Backgrond 30 FPS.

This is basically a stock, out of the box Sierra 10.12.4 MacBook Air.
the only way i was able to fix this issue with my MBP was to run in clamshell mode, i.e. keeping the laptop lid closed while using the external display. it's not a fix for all mac users that use a second display, since imacs and mac pros can't "close the laptop screen", but for my MBP and rMBP users out there, unfortunately we have to forgo dual display and close the lids on the laptops to get rid of the game shifting up 1/3 of the second display screen.

if specs are needed for what i am using i have a:
2014 15" retina MBP
quad core i7 2.2ghz
16gb ram (non upgradeable on rMBP's so it's what apple gave me from the get-go)
Intel Iris Pro graphics ( I got this laptop for free from my school/job, graphics not by choice)
512gb SSD

this tho does not solve my constant 5 second lags where the game just freezes for exactly 5 seconds at a time, but at times it's doing this 3-5 times in a row which adds it up to 15-25 seconds of a frozen game. Me being a heals, this can be detrimental in a raid or dungeon, one second you're throwing out a heal on the tank, then all of a sudden frozen. then after it finally unfreezes half your group is almost dead or completely dead... not cool
Something similar is happening to me after 7.2. I have a dual monitor setup, and the primary monitor (at least from the OS's perspective) is rotated 90°. If focus is on that monitor when WoW runs, then the window draws halfway offscreen. If focus is on the proper monitor, it works fine.
Is there anyone a Blizzard who can give us an update on this?
04/04/2017 06:35 AMPosted by Rockadee
Hi guys,
This is a problem in Mission Control (yes its your Mac). Go to System Preferences => Mission Control => Uncheck Displays have seperate Spaces => Reboot.


I'd tried this, but it doesn't worked for me. The only difference i saw was the menu bar, it's only visible on the main screen for me now.

It's weird because, today i opened Heroes of the Storm to see the news and, Heroes works in fullscreen mode on my external window.
Can someone at Blizzard provide update on this issue? Even if it's "hey we're still working on it". It's been over 2 months. Windowed full screen still does the shifted up thing. if I select the thunderbolt monitor and the correct resolution, when I hit apply it shifts the window to the laptop screen, where only about 1/4 of the bottom left is displayed and I can't get to the top to drag it over where it should be. I can set a custom resolution by resizing the window, but it's laggy and looks terrible.

I've tried all the suggestions on this thread, nothing has worked.

I'm happy to provide any debugging info I can.
*Knocking on wood*, but it seems like the patch today fixed this issue. At least for me I don't have to do the trick to change the the display options and move my game from the external monitor, to my MBP and back to my external monitor anymore. Not sure if that was included in the patch notes, but it seems to be working for me now.

Join the Conversation

Return to Forum