macro for swipe requires cat form

Bug Report
In 7.2, guardian druid, bear form, the following macro

/cast swipe

generates the error "Must be in cat form"
Works fine for me, both in feral and guardian specs. Is there something else in your macro?
It did the same for me yesterday just after the patch dropped. I'd pop out of bear form, back into it and it would work again.

Didn't happen to me today though, so I assume it was hotfixed or I was lucky.
03/29/2017 03:08 PMPosted by Morkathiron
Works fine for me, both in feral and guardian specs. Is there something else in your macro?


There was, but I removed everything except /cast swipe.
And today it works. Must be magic :).
Other similar malfunctions have been resolved by changing spec. Naturally you can change back afterwards.

Can't hurt to try.
I am having the same problem.

In cat form for me swipe is part of a macro. It worked part of the time but stopped working at really bad times.

In bear form swipe is not part of a macro and I still had the same issue this time with it defaulting to the cat form version making it unusable in bear form.

I'm not sure what is causing it to bug out or what makes it reset to work again. When I logged out last night in bear form it had bugged out and I was unable to get it to reset.
03/30/2017 07:21 AMPosted by Asterchades
Other similar malfunctions have been resolved by changing spec. Naturally you can change back afterwards.

Can't hurt to try.


I tried that. Switched back and forth a couple times. Also logged off and logged back in.

I suppose this will be filed under "only seen once, can't reproduce." :)
This happened to me last night.

Guardian spec with feral affinity, my swipe macro started showing that it required cat form while doing WQ in Suramar City.
    I opened my spellbook and swipe worked from there.
    Dragged the spell to my bar and it worked from there.
    Used shift-click to re-add swipe to my macro, still showed it required cat form.

Then went to do WQ Operation Murloc Freedom and switched to cat spec with balance affinity. While in that quest area my swipe showed that it required bear form. When we left the area the swipe macro worked correctly.
The issue is STILL happening. The way to fix it (for me) is to swap to cat form (cat form, not cat spec.. takes a whole 1-2 secs and can be done while in combat), then back to bear form and the macro will work for the rest of the time i'm logged into my druid (but has to be done once again the next time I login my druid).

I am also having the "throw glaive" macro issue everyone is having as well on my Demon Hunter.

Obviously a lot of bugs have come out of 7.2, hopefully they'll be hotfixed soon, I think 48 hours is a bit long of a wait for a simple fix iMO.
Having the same issue - macro worked just fine yesterday, but today it is broken and logging, spec changing or interface reloading does not help. Hope for a fix soon.
I'd like to know if changing into cat form then back into bear form works (brings back swipe ability) for anyone else, or if i'm just lucky.

Also.. i've noticed that i've also been having this issue while in cat spec and it tells me I need to be in bear form to use the skill. Once again, I just pop into bear, back into cat, and the issue seems to be resolved until the next time I login my druid.
Bump
Right now I can with almost 100% guarantee generate this issue by switching between feral and guardian at any point within the same game session. And the only fix, that works for me is straight up restarting the entire game.
Had this happen again Tuesday when I switched to Guardian spec after one of our tanks DC'd. I had to drag swipe out from my spell book while tanking the encounter, as it said "requires cat form" every time I tried to cast swipe with my macro...I did not think to try switching to cat form and back as a fix, but will try that next time.

After I switched back to feral spec my swipe macro still would not work, instead saying "requires bear form." A relog resolved the issue.
Still getting this bug, I use this macro in both Feral and Guardian specs:

#showtooltip
/cast [nomod]Thrash
/cast [mod:shift]Swipe

  • Note what spec you login as (guardian, feral). This macro will work as intended 100% of the time in this initial spec
  • Change to your alternative spec (feral, guardian), you will now get the error Must be in Cat/Bear form
  • Reconnecting in the spec you want the macro to work in, makes it work as soon as you reconnect. Just like before, your alternative spec (guardian, feral) will now no longer work until you reconnect or rebuild the macro
  • This can be replicated every time
    Did anyone ever find a fix for this? It's driving me nuts.

    Are there forms, like swipe_bearform, or something that explicitly name which swipe to use? I would much rather have two different macros than one that is broken as often as not.
    VERY VERY simple fix guys.

    As posted above just change in to cat form (stay in Bear spec) and then back to bear form.

    Then you macro will work again.
    Still a problem as of 12/14. Can confirm that shapeshifting to cat form and then back to bear form seemed to fix the issue.

    I was in restoration spec when I entered the game, then switched to guardian spec with restoration affinity. "Swipe" in a macro gave error "must be in cat form".

    Join the Conversation

    Return to Forum