[unsupported: Linux/Wine-2.0] Patch 7.3 broken?

Technical Support
I think there is no need to compile wine-overwatch... I downloaded precompiled binaries from https://lutris.net/files/runners/wine-overwatch-2.15-x86_64.tar.gz, unpacked them at /opt and using the wine binary from this package, I managed to play the game.

Using Linux Mint 18.2 (Ubuntu 16.04 derived) here.
Funnily enough, it launched under the latest wine-staging for me, as well as during use of the overwatch binaries linked above. I can get to the character list, but once I try to enter the game, it'll crash out at the final step of the loading screen with an access violation

Running 16.04 here also.
08/29/2017 02:13 PMPosted by Pontudinho
I think there is no need to compile wine-overwatch... I downloaded precompiled binaries from https://lutris.net/files/runners/wine-overwatch-2.15-x86_64.tar.gz, unpacked them at /opt and using the wine binary from this package, I managed to play the game.

Using Linux Mint 18.2 (Ubuntu 16.04 derived) here.


Steps I did:
1) remove old wine-staging folder;
$ sudo rm -rf /opt/wine-staging
2) download version you told above;
3) uncompress and rename it to 'wine-staging';
4) moving to same path /opt/wine-staging;

After that just load Lutris/WoW Legion and pushed play... and nothing!

Could u tell us how did u make it work?
Copied over from: https://us.battle.net/forums/en/wow/topic/20758857016

08/29/2017 01:27 PMPosted by Isaacnewtoon
08/29/2017 11:12 AMPosted by Tacker
FYI - If you use Lutris to run WoW, go into Manage Runners, then choose Wine - Manage Versions and select the Overwatch 2.15 x86_64. Once that's downloaded, in the Warcraft icon, right click and configure, go to the wine version section and change it to use the new overwatch one you just downloaded. Came right up after that for me.


I use Lutris!
It worked for me! Thank you, thank you thank you!!!
I was getting a bit overwhelmed reading through the proposed solution listed at winehq https://appdb.winehq.org/objectManager.php?sClass=version&iId=33768 by user chiro, involving https://github.com/gamax92/wine-overwatch

Side note: Lutris makes gaming on Linux super easy and I highly recommend it!


Trackers fix also worked for me.
1. Downloaded Lutris https://lutris.net/downloads/
2. Downloaded battle.net https://lutris.net/games/battlenet/
3. Downloaded WoW [didn't let it reinstall itself with the 40gb, just on lutrix] https://lutris.net/games/world-of-warcraft/
4. Redirected Lutris's battle.net to load to my already installed WoW.
5. Then followed Tracker's comment [unpacked it in my download folder and lutris auto-found it in the dropdown menu, though I also downloaded overwatch but didn't let it fully install too].

Loads fine now. Thanks heaps :hugs: forums.

08/29/2017 02:13 PMPosted by Pontudinho
I think there is no need to compile wine-overwatch... I downloaded precompiled binaries from https://lutris.net/files/runners/wine-overwatch-2.15-x86_64.tar.gz, unpacked them at /opt and using the wine binary from this package, I managed to play the game.

Using Linux Mint 18.2 (Ubuntu 16.04 derived) here.


The Overwatch 2.15 x86_64 can be found from the above link.
08/29/2017 04:45 PMPosted by Garfyeld
08/29/2017 02:13 PMPosted by Pontudinho
I think there is no need to compile wine-overwatch... I downloaded precompiled binaries from https://lutris.net/files/runners/wine-overwatch-2.15-x86_64.tar.gz, unpacked them at /opt and using the wine binary from this package, I managed to play the game.

Using Linux Mint 18.2 (Ubuntu 16.04 derived) here.


Steps I did:
1) remove old wine-staging folder;
$ sudo rm -rf /opt/wine-staging
2) download version you told above;
3) uncompress and rename it to 'wine-staging';
4) moving to same path /opt/wine-staging;

After that just load Lutris/WoW Legion and pushed play... and nothing!

Could u tell us how did u make it work?


Just to let you guys know... I managed to make it works after changing an option at WoW Configuration to use 32-bit version
I was able to build the gamax92 repository from git.
This indeed allows to get past the the DRM as far as I can tell, and I was able to login with a few characters.

WoW seems to be more edgy and crash more often than before, and I currently have two characters stuck: One is in Frostwall and other is in Stormshield. Game will crash after logging in and the loading bar hits 100% when trying to login to these characters.
08/29/2017 04:45 PMPosted by Garfyeld
08/29/2017 02:13 PMPosted by Pontudinho
I think there is no need to compile wine-overwatch... I downloaded precompiled binaries from https://lutris.net/files/runners/wine-overwatch-2.15-x86_64.tar.gz, unpacked them at /opt and using the wine binary from this package, I managed to play the game.

Using Linux Mint 18.2 (Ubuntu 16.04 derived) here.


Steps I did:
1) remove old wine-staging folder;
$ sudo rm -rf /opt/wine-staging
2) download version you told above;
3) uncompress and rename it to 'wine-staging';
4) moving to same path /opt/wine-staging;

After that just load Lutris/WoW Legion and pushed play... and nothing!

Could u tell us how did u make it work?


I did not use Lutris (in fact, I only learned of its existence today when seeing another post), only their wine-overwatch package. I unpacked it at /opt and used the following command:

/opt/overwatch-2.15-x86_64/bin/wine $HOME/.wine/drive_c/Program\ Files\ (x86)/World\ of\ Warcraft/Wow-64.exe

I forgot to mention that I also use an NVIDIA card with Bumblebee, so I also put "__GL_THREADED_OPTIMIZATIONS=1 optirun" in the command line.
Okay, I found out that my stuck characters can be resolved by using DX11 graphics mode ...
08/29/2017 05:37 PMPosted by Stevner
Okay, I found out that my stuck characters can be resolved by using DX11 graphics mode ...


Welp, Lutris was definitely the easiest way to get the game to launch, but as soon as I ported to IF my char got stuck and I don't have dx11 as a choice :[ Can we get a list of which zones are causing problems?
08/29/2017 01:11 PMPosted by Laurapetri
I am running 2.4-staging on Artful and WoW stopped working since the patch. Client launches but nothing is displayed in the window.

No solutions or ideas yet, just a "its broken for me too"
I'm with the same issue as you. Even The theme music plays but no image appears. I use the same wine version as you. Trying to find the solution for this too :/
I had it working for a little bit with Lutris but now it's crashing with access error on every load. Started when I went to Broken Shore, for what that's worth.

Currently reinstalling the game, I'll try it with dx11 mode and see if that makes a difference. Is dx11 supported by wine now? I was under the impression it wasn't.
08/29/2017 08:13 PMPosted by Dymaxion
Welp, Lutris was definitely the easiest way to get the game to launch, but as soon as I ported to IF my char got stuck and I don't have dx11 as a choice :[ Can we get a list of which zones are causing problems?

When I was using DX9, I just used the portal in garrison (Lunarfall) to Stormshield and got a character stuck. I had a character camped in garrison (Frostwall) and it likewise hung/crashed when finish loading at 100%.

I wonder how much DX9 is being maintained, seems it might be bitrotting like OpenGL.

08/29/2017 09:54 PMPosted by Benoice
Currently reinstalling the game, I'll try it with dx11 mode and see if that makes a difference. Is dx11 supported by wine now? I was under the impression it wasn't.

It looks like you need a later version of Wine, it looks like 2.15's DX11 is not too shabby; 2.0's DX11 seemed to work OK as well IIRC. I was not actively testing it because I was assuming as my old video card probably would work poorly with DX11, but turns out it's not too bad. A couple of problems I had in DX9 seemed to have gone away:
- switching away from WoW while on a loading screen, even if the window is still visible, increases chance of a crash
- minimizing the WoW window and restoring it would make the screen completely blurred out and unusable
- and of course the above...
08/29/2017 05:32 PMPosted by Pontudinho

/opt/overwatch-2.15-x86_64/bin/wine $HOME/.wine/drive_c/Program\ Files\ (x86)/World\ of\ Warcraft/Wow-64.exe


This initally worked for me, thanks. Got me to login screen.

Then I log in and

BLZ51900007

error.

Fairly stock OpenSuse 42.2

Newest Nvidia Linux Download

----
After this, I renamed Wow 64 to something else, forcing wow 32. I got that same error still.

I guess this is a "Wow Vacation, while playing the Xbox one (if only cuphead was already out!), for me. Judging by the Tech support forum, of users using the native OS (windows 10), it isn't just us.
dx11 makes no difference, still getting that same access error every time I try to load a toon. Using Lutris with the overwatch fork of wine.
One odd thing I noticed in Ubuntu 16.04 with Wine 2.4 (Staging) is that WoW will bring up a window but not draw anything - until - I paused and resumed it (kill -STOP $wowpid ; kill -CONT $wowpid). This got me to the character selection screen and up to the blue bar getting about 90% across before WoW hung apparently permanently. No luck past that, and the strace output when it's in that state are pretty odd looking.

I'm probably going to wait for the PPA update, since I have the new Zelda to play in the interim ;-)
I'm using Fedora with Bumblebee, and to get WoW working I needed to put wine on XP mode, starting WoW through Battle.net.

I'm also using Lutris to start WoW with primusrun.
The version of wine that I'm using is the Staging from WineHQ repo: https://www.winehq.org/download
08/29/2017 11:10 PMPosted by Kybeorie
08/29/2017 05:32 PMPosted by Pontudinho

/opt/overwatch-2.15-x86_64/bin/wine $HOME/.wine/drive_c/Program\ Files\ (x86)/World\ of\ Warcraft/Wow-64.exe


This initally worked for me, thanks. Got me to login screen.

Then I log in and

BLZ51900007

error.

Fairly stock OpenSuse 42.2

Newest Nvidia Linux Download

----
After this, I renamed Wow 64 to something else, forcing wow 32. I got that same error still.

I guess this is a "Wow Vacation, while playing the Xbox one (if only cuphead was already out!), for me. Judging by the Tech support forum, of users using the native OS (windows 10), it isn't just us.


I made everything (except compile wine from git) above and still not pass through the char selection screen... really sad, i just came back since Cataclysm.

I'll try to compile/make but I'm very frightened about that though
Currently stuck over Northshire. Every time I go near that area, I crash. I was able to get out of it, but I spaced and took a flight path out of Stormwind, and I'm currently stuck over it. I can load other characters just fine. WoW or WINE? And what's the best way to get this fixed? gamax92 seems to be focused more on Overwatch, and is there any attempt to merge those fixes in stock WINE? (Or even Wine-staging?)

ETA: switching to dx11 got me unstuck. But I keep crashing anywhere near Burning Steppes now.
I got the problem using Wine 2.4 stagging, the window opens and there was no image, just the theme music. Then I changed the wine version to 2.12 stagging, installed dotnet40, and d3d11. With this I entered on my character list. By the side of the login button there was a warning sign informing my computer is out-of-date. Never saw that before. Clicking "Enter World" the loading finishes and the game crashes. I use Debian Jesssie with PlayOnLinux

OBS¹: I changed in wineconf "Windows XP" to "Windows 10" and the "out-of-date Warning" disappeared. I'll inform any new attempts

OBS²: The game for some reason logged in. I'm able to play. I noticed a little drop of FPS. I'll test some areas of Azeroth seeking for crashes. I'm using directX 11 in advanced settings

Join the Conversation

Return to Forum