Ground Effects Invisible in ToS 7.3

Mac Technical Support
Same here in Mac OS Sierra.
Also having these issues. Folks in https://us.battle.net/forums/en/wow/topic/20758758309 , too. Huge issue suddenly not being able to see harmful effects.
08/30/2017 06:25 PMPosted by Nut
I cannot see ground effects in ToS post patch.

Cannot see
Feel fire on Goroth
Aqua pools on Harjatan
Crashing wave on Mistress
Green pools left by eels on Mistress
Green residue trail on DH
Purple circles on DH
Tormenting cries on DH

I stopped playing after those fights.
I have tried upping/lowering enabling/disabling all the graphics settings. I have disabled all my adding with no change.

I am on mac. Is this happening to anyone on PC?


I have exactly the same problem on my Mac in ToS
Are you hearing us,Blizzard?
Blizzard is aware of the problem. They posted about it in this thread. https://us.battle.net/forums/en/wow/topic/20758847141?page=4
I have the exact same problem. I'm currently just starting to look for solutions. I am also on a Mac. If anyone finds a fixin please let us know.
To clarify. All ground textures that the personal UI does not cast (death and decay shows up) do not show up. Enemy ground effects are not seen by the user interface.
09/10/2017 12:14 PMPosted by Jpj
I have the exact same problem. I'm currently just starting to look for solutions. I am also on a Mac. If anyone finds a fixin please let us know.
09/10/2017 12:15 PMPosted by Jpj
To clarify. All ground textures that the personal UI does not cast (death and decay shows up) do not show up. Enemy ground effects are not seen by the user interface.

09/06/2017 03:27 PMPosted by Rommax
The OpenGL rendering issue is unfortunately complicated. There were several changes in 7.3 to make systems like particles and projections run faster. While DirectX (Windows) and Metal backends benefited from these changes, it appears for OpenGL they exposed a bug. It's not clear yet whether it's a bug in WoW's OpenGL backend or a bug in Apple's OpenGL driver. We're investigating it and are hopeful to come up with a fix or workaround but don't have an ETA on anything yet.

If your Mac can be updated to the latest version of Mac OS 10.12 Sierra and can use Metal that will fix the issue.
The solution for those on Macs that can't use Metal and have to use Open GL unfortunately is to use a Windows installation with Bootcamp and DX11.

https://us.battle.net/forums/en/wow/topic/20758847154?page=1#detail
https://us.battle.net/forums/en/wow/topic/20758847141?page=6
Two of my Macs that I play on (both 27") cannot use Metal. But even MacBook with Metal I cannot see the ground effects.

I can't see bad stuff on ground. Even my Demoic Circle and Rifts most times show as a silhouette. Not seeing ground effects is HORRIBLE on heroic. Thing is before the patch that removed the new water textures, I didn't have a problem with frame-rates. Only glitches were lava and green pools but was livable. I would love a roll-back.

My main iMac is a 27" 3.4Ghz i7, 24GB RAM, 6970M 2GB that I use for work. It was enough for WoW at 2560x1440 but only OpenGL.

:'(
I have been having these same issues ive tried everything to get this fixed with my graphics and everything. Ive been raiding in ToS but its been very difficult to do this since its heroic content. Maiden is almost just horrifying when you get hit by the wave everytime. Ive been just waiting for a fix since Blizzard does fix these type of issues very quickly i just thought i would post something also just because its been 2 weeks now and its not getting better. It really would be nice to post something at log in for all players to see tho just so raiding guilds and other players etc know about this problem so some of us still trying to do content can still do content without being replaced in raiding guilds to do this content thank you much for your time.
My Mac can not do Metal, so I installed Windows 7 64 bit on a separate SSD and WoW is working perfectly with DX 11 on my Radeon R9 280x graphics card. The graphics are way smoother on DX 11 than they ever were on Open GL.
Just as an update, we have found a fix for invisible ground effects with OpenGL and should get a hotfix released soon, assuming internal testing goes well.
09/11/2017 02:40 PMPosted by Rommax
Just as an update, we have found a fix for invisible ground effects with OpenGL and should get a hotfix released soon, assuming internal testing goes well.


Mad. So mad. This is the start of the THIRD week of raiding with these ground effects being invisible. You have essentially forked me from achieving AOTC with my guild.

I'll say it again: MAD.
09/11/2017 02:40 PMPosted by Rommax
Just as an update, we have found a fix for invisible ground effects with OpenGL and should get a hotfix released soon, assuming internal testing goes well.


thank you! Looking forward to seeing it!

It's been a long few weeks!
09/11/2017 03:43 PMPosted by Aia
09/11/2017 02:40 PMPosted by Rommax
Just as an update, we have found a fix for invisible ground effects with OpenGL and should get a hotfix released soon, assuming internal testing goes well.


Mad. So mad. This is the start of the THIRD week of raiding with these ground effects being invisible. You have essentially forked me from achieving AOTC with my guild.

I'll say it again: MAD.


I got AOTC last night with my guild last night despite the graphics issue. It really doesn't affect the Kil'jaeden fight as the only thing you can't see is the puddle from the orb near the end of the fight. Just stay away from where it hits.
Not sure if the Fix is working as intended but this is what i get after logging now.

https://imgur.com/gPjHZAs
plz keep working on the problem
09/12/2017 12:43 AMPosted by Daazz
Not sure if the Fix is working as intended but this is what i get after logging now.

https://imgur.com/gPjHZAs
plz keep working on the problem


Ah, yes! That is what I'm seeing too. I'm going to update my other post with screens from my computer.
09/12/2017 02:13 PMPosted by Cöhladrei
09/12/2017 12:43 AMPosted by Daazz
Not sure if the Fix is working as intended but this is what i get after logging now.

https://imgur.com/gPjHZAs
plz keep working on the problem


Ah, yes! That is what I'm seeing too. I'm going to update my other post with screens from my computer.


Ditto. Raiding ToS was joyously "complete" again (amazing how much easier ToS is with seeing ground effects!), but the Broken Isles world is rendering so wrong.

https://imgur.com/a/i9IKU

MacPro 4,1
2 x 2.4 GHz Quad-Core Intel Xeon
20GB RAM
NVIDIA GeForce GTX 680 2048 MB

it is worth noting that my Liquid Detail drop down has the Fair, Good & High options greyed out, and Low is the only selectable (selected by default) option here.

Besides the lack of "lighting" on certain types of objects, water is the most noticeable absence in the world.
Aia, unlike most of rest in thread, your gpu actually supports metal, so you're probably not on 10.12.x so it's forced to opengl mode since 10.11.x metal is no longer supported

Upgrading to 10.12.x will get you better performance, more graphics options such as liquid detail, and most of all far less bugs than what opengl has.

That's not a solution to everyone in thread but it is for you.
09/11/2017 02:40 PMPosted by Rommax
Just as an update, we have found a fix for invisible ground effects with OpenGL and should get a hotfix released soon, assuming internal testing goes well.


Rommax, has this fix been applied yet or are you still testing it?

Join the Conversation

Return to Forum