Kil'Jaeden death bug

Bug Report
More often than not, after defeating Kil'Jaeden on LFR/normal/heroic, when the load screen happens it will load several times and when over your toon will be dead (with full repair bill cost). This happens no matter if your toon was at full hp or not.
Is this a problem that occurs for everyone? If not, then I believe it could be your internet that is the problem and not actually a bug.
11/13/2017 09:50 AMPosted by Unknownthug
Is this a problem that occurs for everyone? If not, then I believe it could be your internet that is the problem and not actually a bug.


Internet issues don't cause a toon to just randomly die, and yes other folks have had the same thing happen before also.
This has happened to me twice now. the many loading screens catch me off guard more than the random death
It's happening to me as well on multiple toons. It doesn't say why I died since I am usually at full health and combat log shows darkness hitting me, but not enough to kill me.
11/13/2017 01:16 AMPosted by Darkynhalvos
More often than not, after defeating Kil'Jaeden on LFR/normal/heroic, when the load screen happens it will load several times and when over your toon will be dead (with full repair bill cost). This happens no matter if your toon was at full hp or not.

You are not alone. This happens to me also. I've had it happen in LFR, Regular and Heroic difficulties across different character.
Still ongoing. Please fix.

I don't give a rat's "donkey" HOW easy gold is to make, forced unavoidable deaths are a HORRIBLE thing, bug or not.

Now I hear that forced unavoidable death is actually a design element of the final Antorus fight?? WTF is your problem Blizz??
11/13/2017 01:16 AMPosted by Darkynhalvos
More often than not, after defeating Kil'Jaeden on LFR/normal/heroic, when the load screen happens it will load several times and when over your toon will be dead (with full repair bill cost). This happens no matter if your toon was at full hp or not.
its weird that i've been farming this run for year and never had this problem , and even if repair costs are an issues , you yourself should't be farming raids.
Having the same issue, dying as soon as the CS starts for no reason. This didn't happen when it first came out, only recently saw the issue, then started having it, aprox. the last two weeks. Haven't made any changes.

Also,

11/21/2017 02:04 AMPosted by Riako
its weird that i've been farming this run for year and never had this problem , and even if repair costs are an issues , you yourself should't be farming raids.


None of this makes any sense or is helpful in any way. It hasn't been out a year, and the problem is not that it costs gold to repair, it's that it's done unfairly. Just because you're not having a problem doesn't mean that there isn't one.
This happens to me sometimes, not all the time, it probably is dependent on how my internet and computer are feeling at the time.
I'm getting the same thing, several toons, several difficulties. Boss damage was definitely not enough to kill.
Still happening, several raid members every time the boss dies also die along with him.

Even when nobody but the tanks are taking meaningful damage and everyone is at or near 100% hp.

This may no longer be top-tier content, but still needs fixed.

Join the Conversation

Return to Forum