Artefact points bug

Customer Support
I have made a ticket but just wonder if anyone encountered the same bug as me.

Been the second time now. When my artefact weapon is really low lv, like this morning I just hitted 110 on my druid and when I get a big increase like 210 million in one shot my game bug. Cannot log on that toon again. I can play the others but the game stop responding at the load screen each time for the toon who used the artefact points.Its like too many levels gained in 1 time I think.

Any idea why?
Just so you are aware, a GM cannot do anything about Bugs. You need to post in Bug Reports or use the in-game tool. Submitting a ticket won't do much good.

Have you tried a full UI reset: https://us.battle.net/support/en/article/7549
If you haven't tried a full reset UI, I would.

May not help, but would be a first trouble-shooting step.

https://us.battle.net/support/en/article/7549
Thank you guys, it worked :)
10/19/2017 07:46 AMPosted by Drunkenzrker
Thank you guys, it worked :)


wohoo!
What's an "artefact" tho?
10/19/2017 10:30 AMPosted by Heifertina
What's an "artefact" tho?


Do you not know what they are in general (which I doubt, since you have one equipped), or are you nitpicking the spelling used?

Artefact is just a variant of artifact.
Just so you are aware, not everyone speaks perfect English and can type it as well. Knowing the English language is not a requirement for posting here.

Join the Conversation

Return to Forum