US Purchase Is EU (Transaction Oddity)

Customer Support
I'm not quite sure that this topic is suitable for the forum (customer support) but I was curious on whether or not anyone else had encountered an issue as this.

I purchase from Blizzard quite common, month after month for game time that adds a month onto time that is about to expire (it's not as cheap as a sub, but it works). As someone that plays on US (despite an AU account) all transactions, when completed, come up as BLIZZARD ENT*ONLNSTORE . For some sudden reason, when I purchased the Swiftwind Steed from the store a couple of days behind, it hung in Queue status (which was odd) and completed more than 24 hours later .. only to show BLIZZARD ENTERTAINMENT EU.BATTLE.NET FRA .

I have never seen this before and it worries me.
Not sure why, you did get the mount, yes?
10/14/2017 09:45 AMPosted by Orlyia
Not sure why, you did get the mount, yes?


Yes, the mount was obtained, but the concern is the radical change in the transaction 'addresses' I suppose might be the word. I've never seen the BLIZZARD ENTERTAINMENT EU.BATTLE.NET FRA appear in all my time of purchasing services or items from the Blizzard shop.
That I really don't know.
10/14/2017 09:48 AMPosted by Orlyia
That I really don't know.


I see. That's the part that has me on edge.

I guess sending a ticket to inquire about it might be the best choice then. Thank you for the response :3
10/14/2017 09:47 AMPosted by Keinlona
I've never seen the BLIZZARD ENTERTAINMENT EU.BATTLE.NET FRA appear in all my time of purchasing services or items from the Blizzard shop.


Neither have I, but Blizzard's EU headquarters is in France. Very odd that the payment system would give you that message if you live outside the EU though.

Edit - and yes, putting in a ticket is a good idea. Billing may have more insight into it.
So it would seem this persists (this time for game time) which ended up BLIZZARD ENTERTAINMENT VELIZY VILLAC FR FRA ...different once more, though still the EU branch it would seem. I did read some old, old threads from in 2011 for those that encountered a run in as this, but the difference was they were EU to start with, so it wasn't any help. Some come to the conclusion of stolen cards / and keyloggers and such, but the system is clean.

I've spoken to a couple of the GM's and they have no idea about it (though the services were legit and whatnot - it's just strange).

It seems I have to either wait it out and see .. or stop purchasing altogether. I did leave a thread on General Discussion to see if anyone else has this issue (though the GM said mine was the first ticket encountered).
I'm not sure on whether or not this would count as a 'necro', but the issue does remain as of the current moment and time. Purchased a character boost and will soon have to purchase more game time, but the payments continue to side-line to the EU (despite that, as said, I've always have my payments go to the US side since I'm Australian and are closer to the Americas as far as regions tend to be).

The ticket placed in - and marked as resolved as there was nothing that could be done or even investigated because they are unable to check such information for some reason - did not aid and I'm at the end of my rope. Some people in the EU forum had made the same report / encountered it though.

I'm just ... unsure what to do or make of it. Why does this suddenly happen after all these years?
11/08/2017 02:54 AMPosted by Keinlona
I'm just ... unsure what to do or make of it.


I've had the same, but so far as I can tell I'm not being charged any extra for the privilege of having my cash routed via Europe so I can't say I care a great deal. Its still going to Blizzard, after all.
11/08/2017 03:18 AMPosted by Thelootgnome
11/08/2017 02:54 AMPosted by Keinlona
I'm just ... unsure what to do or make of it.


I've had the same, but so far as I can tell I'm not being charged any extra for the privilege of having my cash routed via Europe so I can't say I care a great deal. Its still going to Blizzard, after all.


I suppose so.

It just tosses me off because it started a month and some behind this year alone, and one cannot be too cautious on unknown domains found in their transaction records. Perhaps it best to calm down .. more so since it seems it's not an isolated issue.

Join the Conversation

Return to Forum