Guild bank very slow

General Discussion
What is causing my guild bank to be very slow when I put something in it or take something out? It takes at least 5 seconds for it to move from my pack to the bank after clicking on it.

My personal bank works fine, transfer is instant.

Any ideas?
I am also experiencing this same issue. I've tried resetting UI, all guild mates are also reporting the same horrible slowness when trying to add or remove items from guild bank. We are running on Dalaran.
Same here
I'm seeing the same thing. Has been going on for about a week now. I think I know the cause.

Net Neutrality

*Sets out cookies and waits*
12/13/2017 02:56 PMPosted by Sorasin
What is causing my guild bank to be very slow when I put something in it or take something out? It takes at least 5 seconds for it to move from my pack to the bank after clicking on it.

My personal bank works fine, transfer is instant.

Any ideas?


i was seeing this same issue a couple of days ago. thought it was just laggy.
It's been an ongoing issue since 7.2, I believe.
Same here on Stormrage. 0 addons, takes a good 4 to 6 seconds to take things from our put things into guild bank.
Yea this has been my issue for months now.
Trying to stock gbank with mats for feasts and it is ridiculous. I have so many stacks of food but it takes like 10+ seconds per item to move in or out.
Mine's working fine. Mostly on low pop realms. Didn't notice an issue on Stormrage but I don't use that guild bank much.
Yeah I've seen this for the past week or more thought it was just my net lol guess it isn't
Logged in to try this on a bank alt. I see nothing out of the ordinary. Hope whatever is wrong for you all gets fixed. IDK if it's been reported.

https://us.battle.net/forums/en/wow/1012660/
There are sooo many posts on the forums about this, and Blizzard refuses to admit there's a problem with the game/servers itself.
Sorasin, you and I are both on the Stormrage server. I recently transferred to Stormrage from a "low" population server. The lag with the guild banks and auction houses is absolutely ridiculous. I didn't have this issue on a low population server.
I've been having this issue on the Wildhammer server as well while trying to organize my guild bank.
My guess is bots, like at the AH. they slow down everything with their perpetual requests.
this is driving me crazy that it doesnt have a fix yet. I cant even organize the bank. I get a slight delay in taking things out to make it harder for thieves if that was the case but GEEZ its sooooo slow and I can move things tab to tab unless I want to sit there for an hour. whats going on blizz? -_-
Same here. I am trying to keep our bank organized, and make feasts/enchants/etc, but I give up after taking 10 minutes just to withdraw the mats.
I've disabled all addons and reinstalled, nothing works. I am the only one in my guild... i have 12ms, run wow on a SSD that I just checked has an average speed of 400mb/s us crystaldiskmark. My processor hovers around 15%, I have 20GB left of RAM and 2 GB left of Video Ram from my dedicated GPU, FPS at 50 world, 30 cities.

Main bank with over 200 slots, instant sorting and deposit/withdrawing, gbank, takes 4s per item in or out.

Its like they want the gbank to verify contents like 10 times before moving them between bag/bank. From what I hear there is suppose to be a .4s delay its 4 seconds now so that 10x.
If I had to hazard a guess it'd have to be something to do with CRZ/sharding, maybe also because of communities? All I know is I disabled all my addons and had >50ms ping and it took my more than an hour to shuffle around some items and reorganize my bank.
It would be nice if they would fix this crap.

Join the Conversation

Return to Forum