Black Character Select Screen

Technical Support
Same thing for me:

https://cdn.pbrd.co/images/H3gWpXu.jpg
I tried a scan and repair. No dice. :(

https://us.battle.net/support/en/article/7655
Same here. It's a good thing this forum doesn't allow profanity.
Does anyone have a solution for this or is it just: Wait 4-5 minutes and hope your screen changes?
yeah, same... ''/
Blacked out as well on every server for me.
[#Warcraft] We're aware of "Character Not Found", "Character Creation Timed Out" & black character screens when trying to log in. This is due to the number of players attempting to log into game currently. Please try again later.


https://twitter.com/BlizzardCS/status/953438985291939840

Except...everyone else in my guild can login without any issue. >.<
Another 80MB patch just hit. Still having the same problem post-patching.
Still have the problem after the patch
Same black screen here... so bump
Same as you guys :(, even if the interface loads, i cant go inside cuz of the character not found problem
I am having the same issue but my characters will come after 30 second or so but when i i try to log in to one of them it will go back to the character screen saving character not found.
Also experiencing the initially black character select screen. After waiting it will load, but when I try to actually login to a character I get the "Character not found" error and am kicked backed to the character select screen:

**EDIT** They are aware of the issue, for several people running the Scan & Repair option in the Blizz launcher fixes the problem. For others (myself included) this doesn't seem to make a difference.

https://twitter.com/BlizzardCS/status/953438985291939840
Yep, I hear you guys, watching my kiddo in a raid.. I have the character black hole screen... still.
I ran the repair client, it fixes it.
Same, same, and same.
same thing here
Same problem as everyone else, scan, restart, got the patch, blah blah, nothing.
01/16/2018 06:36 PMPosted by Holyveil
I ran the repair client, it fixes it.


Not guaranteed, sadly. I did this as well and it didn't help.
same here, thought i was the only one :(

Join the Conversation

Return to Forum