Found a way to get Realm and Character lists to run normally!

Technical Support
Did this completely by accident. was so bored that I ran a cinematic and just let it run to the end. When it finished, my character list popped up with all my toons, just like normal. Logged out of the game completely and back in to make sure it wasn't a fluke. Game runs perfectly normal now. Realm lists show my character numbers and all my lists are working fine!

Edit: In case you don't know: When you get to your character select screen, in the bottom left hand corner are 2 buttons. one for add-ons and one for cinematics. select cinematics, pick one from the list and let it play thru. When it ends your character list should pop up with your toons.

re-edit: If your problem is a crashing game, I cant help you. Sorry. Not a techie. Found this by luck.
"ran a cinematic"? Which one? Where?
What if game crashes as soon as it opens? I can't even get to login or character screen.

> Hit play> Game Crashes immediately
Any of them. when you select a realm and your character list pops up? Down in the left hand bottom corner of your screen is the add-on button and a cinematics button. Just hit that and pick on. Let it run and when it ends your list will pop up with your toons.
@Virtok Have no idea on that. Did not have that issue. Sorry.
Can't get to the character list or select a realm screen. It crashes on loading.
worked for me....had just a blank toon screen so I went down clicked on Menu in lower left corner and watched BC and when it was finished I could see all my toons...
H O L Y C O W. I don't know how but it works!!! Love you darling <3

Edit: my screen was all black. I watched the first video (hope it was shortest.. who knows)
holy crap it worked... bravo bud.. bravo
Honestly, thought you were trolling. It really worked haha. Sorry for doubting you by 100%
It worked thanks.
it works! thnx
I wasn't very optimistic about this method, but i just tried it after being locked out all day... and I'll be damned, it worked. I played the classic WoW cinematic from the login screen and just hit esc to exit, logged back in and now I'm in game.
thanks mate
Good find, well done.
Windows
Close open Blizzard programs.
Press Ctrl+Shift+Esc to open the Task Manager.
Click the Processes tab.
If agent.exe is running—or Blizzard Update Agent in Windows 10—select it and click End Process.
Navigate to the folder containing the cache directory:
Press Windows Key+R to open the Run dialogue.
Type %ProgramData% into the Run field and press Enter.
If a Blizzard Entertainment folder exists in the directory, right-click it and select Delete.
Restart the Battle.net desktop app and relaunch the game.
One of my issues was that when I clicked play, it would bring me to the realm selection list, none of the realms I had characters on were showing that I had characters, but I scrolled down and found the realm I wanted and logged into it anyway, and I saw no characters for that realm. Wyrmrest Accord happens to be my one full realm. So I logged out, came here, saw this post and decided since I had not crashed, I might as well give it a shot. Logged back in, there were my characters like normal, and the realm list is populating normally now when I go to switch realms.
I was skeptical to try this but I figured it was a win/win because I got to rewatch a great cinematic either way. Tried and and to my surprise I am now able to get to my character list and select a toon. Try it!
I can confirm that this works if you get to the character load black screen. Watched the WoD cinematic all the way through and when it ended my characters were there! Way to go!!
I also switched to a realm that I did not have a character on and it brought me to the create a character screen. I backed out and went back to the realm list and everything was working correctly again.
Awesome fix it worked for me too Thanks!

Join the Conversation

Return to Forum