Can't queue for island expeditions

BFA Dungeons, Island Expeditions, and Raids
I am 120 and have the quest called 'Island expedition' in the war campaign. It asks me to speak to Capt Flynn Fairwind. Whilst he is at the table and clickable, the continue button is grey and won't let me interact. When i click on the table it thanks me for testing but has no other options.

Have i missed a pre-req, and if so, how can i tell?

This is on a dark iron dwarf lock.

Exactly the same problem for me Horde side, 120 blood elf paladin. My understanding is that I'm not only unable to do island expeditions, it's locking me out of world quests.
Same problem. 120 blood elf DH. I have the quest "Island expedition" but can't use the table to queue for it. Already switched faction to try it but didn't work.
We have identified some new issues with the queue, we're investigating fixes right now, thanks!
Still broke?

I'm level 116 got the quest and nothing when I talk to the guy or click on the table..
05/18/2018 02:23 PMPosted by Muffinus
We have identified some new issues with the queue, we're investigating fixes right now, thanks!

Good to know, will keep checking on my 120 because I really want to test IE and WQ. Until then, I'll just try out some other classes and level them up.
Same on my DK, can't que for world quests or island expeditions
Still broken.
still broke as of today's patch.
Also experiencing the same problem on Nightborne Warrior Gazonga on Silvanas. Has anyone tried leveling a different character and seeing if the problem persists?
On top of this sometimes you are forced to eat a dungeon deserter if you get an unwinnable scenario, ie it bugs out and you cant complete it. so even if you can get into them, they are sometimes bugged themselves :/
Is there an ETA or workaround for this? Im looking into testing a lot of the professions but a decent amount of the patterns seem to be locked behind world quests. Has anyone tried changing from horde to ally or vice versa? seems ridiculos that only a small portion of players are locked out of these. Would be nice if they couldnt immediately fix it, atleast make it skippable for the time being.
Still not working for me as well....
Apparently this new build includes a bug fix, Captain Rez'okun in Zandalar is now offering the "Let's Go!" option for Island Expeditions. Edited: "Transfer Aborted: instance not found". Bug just appears to have moved one step.
I managed to get in after a race change on my lock - didn't try it prior to the race change so can't say that was the solution.
I did finally manage to get in, after another server reset. Now I have the quest to get in by interacting with the table, and the table seems to have implemented its options now instead of just thanking me for testing. Gonna test it tomorrow.
I can get into the Island but if i die i get dc'ed and cant log back in until it resets me back in boralus. Also i was the only one in the island. Do you have to have a group before hand pre made or is it supposed to group people together?
Got to the tutorial island today, completed all the objectives, was told to head back to the ship so we can return to Zandalar. When I get to the ship the quest does not update and allow me to complete it. I had 543/500 resources which was more than enough. No dialog option with the NPC on the ship either.
I can't do world quest, queue for expeditions, or find a way to gain war resources beyond looting them from treasure chests.

I've been trying to gear for heroics, but you know how that goes.

I'm pretty much unable to do anything on my only 120. I'm assuming it's because of this/these bugs here.

Hope there's a fix on the way.

Join the Conversation

Return to Forum