WOW51900322: streaming error

Bug Report
Since the last update, if anyone is getting the streaming error after selecting a character, I narrowed it down to Rarity Addon. I had to remove the WTF settings for it also. Just thought I would share.
I've been getting this error a ton and getting constant/instant DC'd. Disabling all addons fixes the issue... until I go to a transmog vendor. When I attempt to navigate the transmog menus, I get this error and get DC'd. I am very, very frustrated. I also play on linux so I am beyond help anyways :P
I also play on Linux and started getting this error instantly every time I load in. It started yesterday after the small patch landed. Blowing away addons/interface/wtf didn't fix it, and neither did newer wine releases or reinstalling the game entirely.

It runs fine in Windows, so I'll just have to hang out until there's a wine update or someone tracks down the core problem.

Affects: 2.16-overwatch, 3.9-bpa, 3.10-stable
Been experiencing this same issue. Log in to a character, can't move, 5 seconds later DC with the error code.

When I disable all of my addons, the game runs just fine. I've slowly been enabling all of them to try to see which is causing it (I don't have Rarity as someone else mentioned so no issue there)

HOWEVER, when speaking to a xmog vendor the game does indeed DC. Very frustrating

Playing on PBA 3.3 via Lutris
I've been doing more testing, and it's not consistent across characters. I have three level 110 characters that can't log in due to this error (Mage, Druid, Paladin), but all my sub-110 characters (101 Warrior, 91 DK, 22 Hunter) and my 110 Rogue can all log in fine.

It's also not location-specific, since my 110 Pally and 110 Rogue are both currently in Shrine of Seven Stars at the innkeeper - one can login, the other can't.

Addons definitely contribute, since enabling them causes *all* my characters to suffer this error.

I tried switching to PBA 3.3 as Meowfy mentioned, but it didn't make any significant difference.
Been doing more testing as well. I still don't know the exact cause of the problem, but it is confirmed to have to do with addons as well as the xmog vendor. Can't find the missing link between the two.

Some others I've spoken to in the Linux gaming community have said that they're not experiencing these DC issues at all. Not even while talking to the xmog vendor. So far we haven't discovered the difference between their setup and ours that's flipping the error.

(side note) I was on PBA 3.3 just because I'm lazy and haven't updated in forever. Switched to PBA-firerat-3.9 (again via Lutris) and enabled DXVK and it runs beautifully!
Although still not 100% - I think that TradeSkillMaster is what's causing the DC for me.

Again, as Qmindgate said, the problem seems to happen differently on different toons. For example, totally fine on my Mage with the addons that I've determined to work. Log over to my Priest with the same addons.... DC'd.
I felt I should chime in here. I'm also getting this error.

I don't have any addons, but the error causes my game to disconnect when:
*I hover my mouse over SPECIFIC transmog items
*I attempt to open SPECIFIC quest text

I'm running the client under Fedora Linux, Wine 3.10

This means I can't log in onto two of my higher level Horde characters, as new quest text attempts to load upon login, and crashes my game when attempting to progress on a Duskwood quest chain on this character.

I would greatly appreciate a fix, as I don't have a computer running Windows!
The DCs just keep getting weirder and seemingly more random for me. Earlier, playing on my Mage after I'd assumed I had all the dangers put away, I randomly teleported to the Exodar.

Everything was fine until I walked towards the center of the city - random DC with the same error message. Extremely weird!
Heard about this elsewhere. I use Linux with wine set to windows 7 & wine version 3.7. Everything is fine for me. :/ Kind of hoping it won't effect me at all.
I also am getting the error. I am using Dox' All ine one installer on Ubuntu 18.04 (and Debian sid).

I simply cannot login on any character, even with all addons disabled; I get the "A streaming error has occured (WOW51900322)

Was there a hotfix recently that could have caused this?
06/24/2018 06:53 AMPosted by Blaise

Was there a hotfix recently that could have caused this?


There was, just within the last couple days. That's when this error began to happen for me, and I think everyone else as well.

I tested Justapries' suggestion to use Windows 7 on winecfg, but to no avail.

Whatever was in that hotfix is throwing errors to anything that "fetches" data from the servers, such as TradeSkillMaster, AllTheThings, Rarity, etc. Transmog vendors are just an absolute mystery to me in this regard.
So far, I have deleted the Cache, WTF and Interface, as well as trying a complete reinstall.

Can a blue poster from Blizzard check if a recent update could be the cause of this? Realise Linux is not supported, but would be interesting to know what exactly is causing us to not being able to play, maybe we can forward that info to the Wine devs.
I spent some time trying to pinpoint the issue. I have disabled all my addons, deleted the Cache, Interface and WTF folders. Fresh reinstall of the game (100% done downloading too). I logged on each of those characters on Windows to see if there were quests popup, etc.

I didn't compare inventories as that would have taken quite a long time.

Characters that can login into the game:

Class (Level / Zone)
Priest (110 / Dalaran)
Mage (100 / Garisson)
Paladin (102 / Dalaran)
Hunter (110 / Trueshot)

Characters that can't login into the game (A streaming error has occured)

Class (Level / Zone)
DH (104 / Dalaran)
Rogue: (110 / Dalaran or Durotar)
Monk (110 / Dalaran)
Warlock (110 / Dalaran)
Shaman (110 / Dalaran)
DK: (110 / Dalaran)
Update:

After having logged on all my charactrers from Windows:

I tried copying my Cache/ folder from my Windows install to my Linux one, and it seems to have fixed the issue for me.

Can anyone else try and confirm?
06/25/2018 10:16 AMPosted by Blaise
Can anyone else try and confirm?


I'd love to confirm, but I don't have a windows install to grab from. Sorry =(
Looks like some linux players in the EU are having the same problem, and it looks like one of them has confirmed a possible workaround of using the cache files from a actual windows installation.

https://eu.battle.net/forums/en/wow/topic/17620282020
https://eu.battle.net/forums/en/wow/topic/17620271965

I will also test this once I have access to a window's installation. Also There are reports that this does not seem to be an issue in the test servers, so hopefully this workaround does not become a way of life.
@Cowmora, yes, the fix they propose is the one I posted just above ;)
I'm happy some of you have found a fix!

I'm still in search a fix though, one that does not require use of a windows computer...
This is the first character that I haven't been able to log into at all. She's in her Garrison at Lunarfall, and as soon as it loads into the game itself (after the load screen is completely cleared), it crashed with the error message as above. My other characters (including all level ranges from 1-110, all races/classes, both factions) have had varying levels of disconnect frequency, but I've been able to play them. I no longer have the Windows files on this system, and have no desire to install/piggyback Windows to reinstall the game just to get the cache files. If anyone has a link for a "premade" set of usable cache files, please let us know.

Join the Conversation

Return to Forum