"Your Device Driver is not compatible."

Games, Gaming and Hardware
I'm using an RX580 8gb (which is listed in the compatible video cards section). While the servers were down for maintenance, I went ahead and updated my driver to the most current production driver (no, I'm not using a BETA driver). My old driver version was 18.4.1. My updated driver version is 18.5.1. I updated using the official AMD Radeon Settings program.

I'm not sure if this is a bug related to WoW's 8.0 update, if they need to update the game to recognize the new AMD driver update, or if it's a bug on my end. This doesn't really effect gameplay, it just gives me an annoying message every time I open WoW and an annoying popup on the character selection screen.

Any ideas?
You may have to completely remove your AMD display drivers then reinstall them from scratch just to be sure it is not your drivers. It could just be a simple bug too with the game itself.
Can confirm, reinstall WoW fixed it for me

I too have RX 580, Vega 56 and Vega frontier

I know for sure Vega Frontier is an extreme Overkill for WoW so seeing that error made me lul
Is this the 20% AMD GPU performance boost due to DX12 the A+ certified tech was talking about? The advantage AMD has over Nvidia?
07/17/2018 11:23 AMPosted by You
Can confirm, reinstall WoW fixed it for me


That sounds like it would take a long time, couldn't you've done a repair?
07/17/2018 11:43 AMPosted by Urwrong
Is this the 20% AMD GPU performance boost due to DX12 the A+ certified tech was talking about? The advantage AMD has over Nvidia?


I've got an RX 580 and I logged in with no issues and don't see any performance benefit over my 1060 3gb machine
07/17/2018 12:23 PMPosted by Tyrealle
07/17/2018 11:23 AMPosted by You
Can confirm, reinstall WoW fixed it for me


That sounds like it would take a long time, couldn't you've done a repair?


Now that you mention it..

I could have just done that instead

Oh well, damage was done already
In case anyone else runs into this issue, there was a blue post in the Technical Support Sub-forum saying that AMD users must use the beta driver version 18.7.1.

Update: I installed the driver, restarted the PC, and launched the game. Can confirm... Blue post was correct. We need a beta driver to get that message to go away.
07/17/2018 03:20 PMPosted by Healsgohere
In case anyone else runs into this issue, there was a blue post in the Technical Support Sub-forum saying that AMD users must use the beta driver version 18.7.1.

Update: I installed the driver, restarted the PC, and launched the game. Can confirm... Blue post was correct. We need a beta driver to get that message to go away.
07/17/2018 03:06 PMPosted by Ibaraius
Hey, all!

You will need the newest driver available to get past this error:

That means 398.36 for Nvidia and Adrenalin Edition 18.7.1 Optional for AMD.

Please go here and find the driver you need for your specific card:
http://www.nvidia.com/Download/index.aspx

https://support.amd.com/en-us/download
So don't waste your time removing and reinstalling WoW
07/17/2018 11:43 AMPosted by Urwrong
Is this the 20% AMD GPU performance boost due to DX12 the A+ certified tech was talking about? The advantage AMD has over Nvidia?

i feel dumb because im an A+ tech and dont really know too much about dx12. maybe being customer facing for simple tech problems has watered me down too much
I installed 18.5.1 and had the explanation point near my characters' name go away. Use the AMD autodetect:

https://support.amd.com/en-us/download/auto-detect-tool
07/17/2018 11:43 AMPosted by Urwrong
Is this the 20% AMD GPU performance boost due to DX12 the A+ certified tech was talking about? The advantage AMD has over Nvidia?


Doubtful, I'm seeing a big jump even on DX11 with my 1070. I used to sit around 60 FPS in Dalaran, currently sitting around 90.

Join the Conversation

Return to Forum