BfA Pre-Patch: Unplayable FPS/Graphics Issue

Bug Report
Having low fps since the prepatch and the game is just unplayable at 9fps(!!!!) there has to be a fix for this.
Following for this, having the same issue, pretty pissed because I haven't really played wow in about 2 years and really wanted to play BFA. 1080ti's in sli, this should not be happening. I tried rolling back to previous drivers that didn't manage to fix it for me.
08/05/2018 07:23 AMPosted by Thelgren
1080ti's in sli, this should not be happening.


I agree. Sadly, WoW is CPU single-core. If you pull up task mgr or performance monitor and monitor your GPU utilization and your CPU core utilization, you will find GPU utilization rarely breaks 50% while 1 tiny single core on your CPU will be bottlenecking the system at 99%.
I don't know If this is under the right section or not. But what I am experiencing the game will alt tab me out randomly where I constantly have to re click on the screen. Then randomly after playing for 30 minutes to 2 hours it will just say not responding and boot me off the game. The battlenet client stays open, but it exits the game interface completely. Please help!
What does resetting your UI do?
Also experiencing this issue.
My lag is horrible especially when fighting a boss but my game did not do this in legion. What do I need for this lag to stop again?
4790K and 980ti, both water-cooled.

In 7.3.5 and 800+ pulls on Argus, and everywhere else in the world, I was 150+ fps, easily.

For the last 3-4 weeks of prepatch, and even moreso now in BFA content itself, the FPS stuttering and spike-drops are infuriating the crap out of me. Zoomed all the way into a wall, *with lowered settings*, I can watch it skip around between 50 and 80 for no reason at all.

Running around, it drops into the 40s, and during dungeons/boss fights, I'm lucky to get out of the 30s.

I have tried ALL of the following things, and nothing seems to help it:

- Fully uninstalled and reinstalled WoW.
- Disabled all addons + completely removed their folders.
- Updated graphics drivers.
- Fallen back to several older versions of graphics drivers (up to a year+ ago).
- Played with dx11 and dx12.
- Played with v-sync on and off.
- Lowered almost every setting to "Good" or "Fair", when it used to be on High and Ultra.
- Ensured wow.exe is added to my Nvidia control panel's settings as a program.

You name it, I've tried it. This 100% has to be something broken on Blizzard's end, and it's borderline unacceptable with how annoying it is. I'm talking about within 10 seconds, having 3-4 fps drops/hits/stutters.

WTF is going on?
Having a similar issue.

<10 FPS with a 960gt. Legion worked fine.

Tried game delete and reinstall, driver roll back to 397.x, lowering graphics settings in game.

CPU does not appear to be bottle necking and only using 30% of the system memory.

Running out of ideas :/

Thank you,

-poy
I too am experiencing the same issues described in this post.
I have tried everything in the thread and the game still packs up.
We are all looking for solutions, for now add me to the gripe list, unfortunately.
Me too, et all, #BattleForFullscreen
Also experiencing this issue - fluctuating between 10fps in dungeon and 20 in overworld. I've used this mac since Warlords and the game used to run perfectly.
Wow so I'm not the only one with this issue. The game is so laggy it's unplayable!
Having the same issue. I bought a new computer because I thought it was just time for an upgrade but have a new graphics card. SAME ISSUE is still happening. Freezes up constantly during gameplay. Borderline unplayable. This is definitely on blizzards end.

Works great after an Nvidia driver update, blizz patches again and broken again. FIX IT
I'll be testing a 1080 msi card, 2x8 = 16 Dual GHz ram, i7-8700k, Asrocks build directly for OC'ing and 8th gen processors, and I have a 860 evo SSD.

I'll be testing the FPS issue again. Right now I'm getting 35-60 while in Tradewinds Market (Alliance). This is with LOW graphics, and only upped particle density, Depth effects, and turned on Projected Filters so you can see spells. I looked at the resource monitor. The CPU is barley being touched, GTX 970 is barley being touched, and the RAM is only being used by 1/5th.

So! WIth that being said, I'l' come back with some results.
I'm having a similar issue to those mentioned above. Everything was fine all day after today's Patch and then.. I'm running Black Rock Depths tonight, but when I get the killing blow on the Emperor (Last Boss), my computer freaks out and crashes! Had to reset, and the computer froze 2 more times when trying to play WOW before finally settling down. However, now upon log in (after a LONG wait for the load screen), my FPS sits at 0 even though my computer is a BOSS and my internet speed is Red-Hot Fast. Something is MESSED UP and IDK WHAT.. Tried to switch the DX 11/12 in settings, as well as Change graphics settings. No Joy. Help..?

Join the Conversation

Return to Forum