Flickering textures on dx11

Technical Support
nothing so far right?
will they give a refund if they don't fix it?
I can't play like it is.
07/19/2018 01:55 PMPosted by Mauldain
will they give a refund if they don't fix it?
I can't play like it is.


why would they ?
07/19/2018 01:55 PMPosted by Mauldain
will they give a refund if they don't fix it?
I can't play like it is.


So many people have this issue. If it's not fixed they're going to lose A LOT of money in monthly subs and even more if they do refunds. So we'll see..
07/19/2018 02:05 PMPosted by Daaé
07/19/2018 01:55 PMPosted by Mauldain
will they give a refund if they don't fix it?
I can't play like it is.


So many people have this issue. If it's not fixed they're going to lose A LOT of money in monthly subs and even more if they do refunds. So we'll see..


I can deal with some occasional graphical glitches, but not ones of this magnitude. I'll likely quit the game over this because I can't stare at stuff like that for any length of time without getting a migraine. Here's to hoping they fix this soon!
Assuming youre on windows7 since you have older [nvidia] graphics cards.
If you have a nvidia 400/500 series (or older) try an older driver like one from the 200 branch.

http://www.nvidia.com/object/win7-winvista-64bit-296.10-whql-driver.html

Clean install or use DDU
(https://www.wagnardsoft.com/DDU/download/DDU%20v17.0.9.0.exe)
Make sure windows update doesnt automatically update it again on you.

I tried on an older gts450 and couldn't get it to bug out in town on a mage.
YMMV and I tested quickly on a toaster pc
I'm having the same problem, it just crashed my game. I have to play in dx11 because 12 tells me my graphic drivers aren't up to date and they are. I know my drivers are up to date, can ya'll please fix this. It wasn't happening to me yesterday but it is today. I really don't wanna unsub.
07/19/2018 03:52 PMPosted by Srath
Assuming youre on windows7 since you have older [nvidia] graphics cards.
If you have a nvidia 400/500 series (or older) try an older driver like one from the 200 branch.

http://www.nvidia.com/object/win7-winvista-64bit-296.10-whql-driver.html

Clean install or use DDU
(https://www.wagnardsoft.com/DDU/download/DDU%20v17.0.9.0.exe)
Make sure windows update doesnt automatically update it again on you.

I tried on an older gts450 and couldn't get it to bug out in town on a mage.
YMMV and I tested quickly on a toaster pc


I'm on Windows 10 64bit, but I'll try taking the drivers back to the stoneage

EDIT: Actually, I can't because the oldest Windows 10 driver is 382.33 and I remember trying that one already.
Anyone having luck with different drivers? Or..?
Not at all...
GTX 670m 3GB here. Same issue. Driver updates don't help.

Except that it didn't happen prior to the patch when I could use Fullscreen mode.

Windowed and Fullscreen (Windowed) have always given me this problem, as far back as MoP. That is why I don't use Windowed or Fullscreen (Windowed).

The loss of fullscreen mode also causes my framerate to drop to ridiculous levels during raids or "busy" PvP, so..the game is, at this time, unplayable.

Had this change been announced before the pre-orders began, I would not have pre-ordered without knowing there was an incoming fix.
07/19/2018 12:46 PMPosted by Lünà
Same here, using a 820m, and some places like Azsuna, Orgrimmar (specially Warchief hold), Argus (patch between Krokun Hovel and the place where you meet Captain Fareeiya for the first time), the water/liquid on the DH class hall, as all the AOE animations are flickering and textures are missing. Drivers are up-to-date, since the last one for 820m was 391.01.

As for everyone, before the prepatch everything was fine and working as intended.

Hope they fix it before BfA launch.


Describes my problem exactly. Now, I get that BfA was meant to move over into Dx12, but if you're gonna have a Dx11 mode for people who have hardware that's not compatible, someone should be making sure that it's running smoothly. Having a problem with the AOE's flickering on the floor makes it hard to read where the bad stuff is and where I shouldn't be standing. It's so messed up that it's hard to really see where the edge of these circles lies. Was never a problem I had in Legion or previous expansions, only started in 8.0
07/19/2018 11:31 AMPosted by Rustbeard
I'm not sure if this is related but the graphical issue I'm experiencing manifests on ground aoe, but also on all water, some ground details, weapon enchants, and swirly effects around players like shields or shadow form.

Rather than a flicker though, I get solid colors. All affected surfaces (any water is always affected) share the same color and the color remains consistent until either logout or a zone change, then a new color is selected.

nvidia 650 ti, dx 11, running on linux so I realize this may not get much attention :(


^ This is an issue I have
GTX 950 nvidia driver 390.48 dx11 w/monitor 1080p resolution in lubuntu,
Dropping all graphics down to the lowest setting still shows the above in most zones, I can make adjustments here and there and it helps in some textures but others it makes it worse or just weird in general.

Water is generally either solid blue or red too.
07/19/2018 10:10 PMPosted by Darkodin
07/19/2018 11:31 AMPosted by Rustbeard
I'm not sure if this is related but the graphical issue I'm experiencing manifests on ground aoe, but also on all water, some ground details, weapon enchants, and swirly effects around players like shields or shadow form.

Rather than a flicker though, I get solid colors. All affected surfaces (any water is always affected) share the same color and the color remains consistent until either logout or a zone change, then a new color is selected.

nvidia 650 ti, dx 11, running on linux so I realize this may not get much attention :(


^ This is an issue I have
GTX 950 nvidia driver 390.48 dx11 w/monitor 1080p resolution in lubuntu,
Dropping all graphics down to the lowest setting still shows the above in most zones, I can make adjustments here and there and it helps in some textures but others it makes it worse or just weird in general.

Water is generally either solid blue or red too.


Hmm, I run the game in window mode and noticed the resolution scale at 100% which shows as 1920x1027, instead of window size being on custom I simply changed the 'window size' again to 1920x1080. now nothing actually has changed but this somehow temporarily reset or init the graphics while I'm in the middle of a zone and it has got rid of ground texture problems / character display issues.

I wonder if others tried this, does it help?, I was able to adjust my quality slider up to 7 so far while testing this out. (actually slider is on 10 now and no problem at the moment) [need to test this more...]

*update* Thousand needles water was pure black at Graphics Quality 10, reinit the resolution again and BAM water is back to normal again. (I can't confirm yet if this helps anyone on windows)
Blizz needs to go into overdrive to figure this one out cuz a whole population of their player base in unable to play the game. I was glad to find out I wasn't alone in this struggle.
07/20/2018 12:00 AMPosted by Packheffer
Blizz needs to go into overdrive to figure this one out cuz a whole population of their player base in unable to play the game. I was glad to find out I wasn't alone in this struggle.


Seriously. It's really bad! >_<
i understand that DX12 doesn't support Full screen mode. but for the many many people including myself who use DX11 i dont understand why the option isnt there. DX11 supports full screen mode and everything was fine until blizz took that away for some unknown reason. im having more micro stuttering and lower fps because of this issue also running on a gtx 950. This is ruining the new expansion big time for me Blizz please put it back for DX11 users

Join the Conversation

Return to Forum