Call to Arms website won't load characters

Website Bug Report
I've been trying to use https://calltoarms.worldofwarcraft.com/en-us/ but it keeps telling me, "You can try World of Warcraft FREE with the Starter Edition, or get a game subscription to greatly enhance your experience. Getting started is easier than ever before!" It says I need to have been logged in within the last 90 days, which I absolutely have - I just played earlier today. I've tried this on two separate web browsers (Chrome and Edge) and it tells me the same thing. I'm definitely logged in, because it says my battletag at the top and "WELCOME MALVALEN" above the message about trying a starter edition.
Having the same problem. I literally logged out of my account less than an hour ago, cleared my browser cookies and cache, but I'm still getting the error. Are you outside the USA Malvalen? Some of my fellow non-US friends are reporting the same issue.
Getting the exact same error, my b.tag shows, I've logged in to the game recently and cleared cache/cookies.

I'm also in Australia, if that helps?
It wont even let me log into it.
08/03/2018 03:06 AMPosted by Thelootgnome
Are you outside the USA Malvalen?

I am not, I'm in Texas actually. I've only tried from my office so far though, so I'll try again from home when I get a chance.
I have the same issue. Getting msg about trying a starter edition. "Account must have logged in to World of Warcraft within the past 90 days with a character over level 10." I've been logged in and have several at level 110.
I have the same issue, not sure how to fix it.

I think its because for some reason, and since they updated the website, people outside of the US get pushed onto the EU server. Part of the URL says "EN-GB" which if im not mistake is English Great Britain.

I'm pretty sure the Authentication the site does sent to the EU battle net, and thats why it says we don't have an account.
I'm in the US and the website reads en-us at the end so idk what to do.
I have this problem too. Have 2 active starter accounts (which i don't use). Maybe it's causing the issue?
I don't have a starter account at all. I have Live, PTR, and Beta. Opened a ticket and GM told me "not able to see any issues" and "forwarded to devs". Advised me to "post on forums". So I am doing that.
Hello! Having the same issue, and I've brought it up in the Tech Support forums. Drakuloth has directed me to add my information here. You can find my post located at: https://us.battle.net/forums/en/wow/topic/20767346767

The issue appears to be an issue with the website scripting. I'm unable to access the same thing, and I've gone through and even tested it on my mobile phone being tethered to my PC and I get the same thing. I've had my husband and a fellow Perth guildmate test, and they're both getting the same thing as well.

Thank you! :)
Unfortunately I've not been able to get any of my options worked. It seems to not direct me anywhere but the "create a starter account" page despite logging in on:

Mobile (Cell-phone)
Work (Computer)
Home (Computer

Seems whatever the case is it too redirects me to this link:
https://calltoarms.worldofwarcraft.com/en-us/

Then gives me the following image:
https://imgur.com/a/dYdzAQs

For whatever the case, it is being "selective" on who can use this feature.
In the US (Florida), having the same issue. Have tried:

- different browsers
- different computers/devices
- clear cache/cookies/etc
- log out
- reboot
- bounce the modem/router
- log in/out of my characters since I haven't played in a couple weeks (though the website says 90 days)

My husband can use it just fine, I can't. Very very frustrating.
I am getting the same thing and I also live in Australia.
I'm logged in, but its telling me to try a wow account for free with the starter addition, with a nice big button saying 'Play free now'. No other options available.
Tried other browsers and connecting to phone internet. No change.
:(
I'm getting the same issue. Keeps being directed to create a new acccount.
Am in Singapore. Have tried different browsers as well.
Been having the same issue the past few days, got into contact with support about it and they sent me the following:

"Thanks for taking the time to contact me today about your troubles using the Call to Arms website to create a custom character portrait online.

Technical issues are never fun, and trying to get something to work that's not cooperating can be really frustrating, for sure. After testing this out myself, I'm also getting the same issue, so you are in good company! Worry not, we're here to help!

Looking into this issue, it appears to be a known issue with our Web and Mobile site teams at the moment. Our website team is working on other aspects of the site to get ready for Battle For Azeroth, including the Call to Arms page here.

I'm submitting a web site bug reports for this issue and I am including your info as well. If you could submit a bug report to back up my submission that will go towards getting the issue pushed to a higher priority meaning it can be taken care of faster."
Also having this issue, hope there is a fix for it soon
Yep same problem in Australia
Not working for me either.

Singapore (US servers). Have tried from multiple browsers and mobile.
Having same problem here. Also Australia.

Join the Conversation

Return to Forum