Game unhides itself

Mac Technical Support
Hi everyone,

For the past week or two (probably since the original 8.0 patch, but maybe one of the minor updates since then) I've had an issue where the game will sometimes unhide itself. What I mean by this is that I can press Cmd-H as usual to hide the game and show the desktop, but then a short time later the game may reactivate itself as if I'd clicked its dock icon.

If I use Cmd-Tab, therefore keeping the game visible, then this issue does not occur.

Has anyone else run into this? I'm on 10.12.6 with a GTX 960.
This never happened with fullscreen.

>_>
The problem was always intermittent, but I *think* it's been fixed in one of the mini-patches this week as I haven't seen it happen for a couple of days :)

Edit: Argh! Spoke too soon! It just happened again...
I've updated to 10.13.6 and it *seems* to have fixed the problem.
Well, this happens a lot less often now, but it still happens. Am I really the only person that this is happening to? What could be special about my system?
Double check that you don't have Spaces and Hot Corners active in the OS. Both can produce the behaviour you're seeing and you wouldn't know why unless you knew where to look.
Hot Corners are disabled. I've disabled Spaces to the extent that seems possible.

However, I've (finally!) managed to find some steps that trigger this issue 100% of the time on my machine.

1. Ensure that Preview isn't running. Have WoW running in Fullscreen Windowed mode.
2. Press Cmd-H to hide WoW.
3. Open Preview (whether by clicking an image file or launching the app directly).

This makes WoW pop back up over the desktop. Hide it again with Cmd-H, quit Preview, and watch WoW pop up yet again.

Can anyone replicate this?

By the way, it's definitely a new problem in BfA; the 7.3.5-based Classic client doesn't have the issue.
I just tried to replicate your issue and Preview works perfectly for me. Nothing I could do would make WoW unhide itself.

Have you also disabled Exposé as well? Also, could you provide a screenshot of your Mission Control prefpane?

Can you also try something for me? When you open Preview the next time with WoW open (as a test), does CMD-Right Arrow do anything?
Thanks for trying. I've turned off practically everything in Mission Control:

http://junk.toralar.net/images/missioncontrol.png

Cmd-Right doesn't do anything.
Hrm. You still have Show Desktop on and Show Dashboard also on in the control menus. I wonder if that is counteracting Dashboard being turned off in the main pulldown menu.

I suspect you still have Exposé enabled. Follow the tips found in this article. It still works for High Sierra/Sierra even though the question was submitted during Yosemite's time.

https://apple.stackexchange.com/a/295531

You may need to follow the tip regarding exposing all of the spaces that have been created that you may not know about, so make sure to try that.
I hadn't disabled F11 or F12 since I was definitely not pressing them :) but disabling them hasn't helped at all. I've also set mcx-expose-disabled as suggested, with no luck. Ctrl-Up doesn't seem to do anything (whether Expose is enabled or not).

I've also tried creating a new user account and the problem occurs there too.

I'm beginning to suspect the nVidia drivers might be doing something odd, but unfortunately the game won't run without them. I might ask around at work, in the hope that someone has an old "native" card floating around somewhere...

Thanks for the suggestions so far!
Do you happen to have a joystick with an analog stick connected to your Mac? If so, open WoW and cycle the analog stick(s) in a circle a few times and then release them. OS X does something weird with joysticks of that sort where if you don't calibrate them while WoW is open, the OS acts as if the sticks are pressing down, which can unhide the game.

Naturally this only applies if you have a controller with analog sticks connected to the computer. I only mention this as a suggestion as I have one that I used specifically for playing WoW and if I didn't calibrate the controller by cycling the sticks before playing or before leaving the game app, every time I highlighted something it'd press down or attempt to open Spaces if I hit CMD-Tab to switch between apps instead of just bringing up the CMD-Tab mini-window.
Nope, no controller. I just tried unplugging everything other than the keyboard, and it didn't help.

Edit: A different video card, using the Apple drivers, didn't make any difference. That rules out the nVidia drivers doing something weird.

Join the Conversation

Return to Forum