Ability/Loot Lag on Oceanic Servers Despite Normal Latency

Technical Support
Prev 1 2 3 92 Next
Is happening right now, on Nagrand in Kul tiras zones. The lag fairly awful. It would be really good if somebody in charge could say something, or explain what it causing this, its extremely disruptive.
What a god awful launch, considering how smooth Legion was this is a farce
Same here. experiencing this delay mainly in the open world.

I don't experience this in instances or bgs thou.

Caelestrasz server
Same here. Have had the week off and its been fine during the day time (10am-5pm AEST roughly). But later in the evening it becomes a slide show.
Can't stab Hir'eek on his back while flying cause I am out of range...
ill add to the party... right now im getting disconnected constantly but im not sure if the issue is me or this lag...... anyone getting d/c error 51900319?
Sad/Glad to see its not just me. Will just have to wait for a fix. Hope it gets fixed soon, was looking forward to a lengthy session this weekend!
latency is generally 60ish.. been anywhere between 600 and 12000 for the past few days!
Just here to confirm that that this is still taking place and the server lag seems to be getting worse. I'm on Nagrand OCE. Home ms 30 World ms 40's doesnt change but still have massive lag.
Loot..one..two..three...in bags. Use stealth..one..two..three...works.

Massive delays in spellcasting and I died as a result.

Five seconds to buy from a vendor .

Why hasnt a Blue responded to this?
We need answers Blizzard. This is not an isolated incident. Whole servers are laggy.
ive had the same, last night and tonight. Seamed to be just the new continents.
Ran a few alts through the sili quest part and it ran fine, then dog!@#$e in bfa content as soon as i arrived.

Alliance Dath'remar
Horde Khazgoroth

I tried both hoping it was just 1 of the islands

Edit: Optus from Brisbane
Khaz here for me.
Ok in open world for me, however, I play with WarMode on.
Terrible for my wife who plays with WarMode off.

Pretty horrible in BGs as well.
Barthalis.

Horrible lag.
2-4 second lag between spell casts / moves. stealth ect.

hopefully fixed soon.
Nagrand/Cael.

Not in all zones, Logged back to do army of the light emissary on an alt for rep and its fine.

However in Drustvar, horrible, horrible lag.
Nagrand here. It feels like 800ms latency in Stormsong Valley even the game shows only 33ms. Fix this problem please.
Saurfang, driving me crazy. Feels like 1000k+ but showing 100ms
Howdy!

We are currently investigating this issue and need more information to narrow down the problem. When the issue is occurring please run a WinMTR to host IP: 103.4.115.248 for 10 minutes. Post the results back here within code blocks </>. Other information we would like to know:

- Does this latency only occur in Battle for Azeroth zones or anywhere in game?
- When the latency is occurring what does your Home/World latency report. You can see this by placing your mouse over the red question mark next to your bags.

This information will help us greatly! Just make sure to collect it when the issue is at it's worst and during the time frame stated.

Thank you!
08/17/2018 07:39 AMPosted by Zuvykree
Howdy!

We are currently investigating this issue and need more information to narrow down the problem. When the issue is occurring please run a [url="https://battle.net/support/article/000027780?utm_source=internal-TechForum&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=solution"]WinMTR [/url] to host IP: 103.4.115.248 for 10 minutes. Post the results back here within code blocks </>. Other information we would like to know:

- Does this latency only occur in Battle for Azeroth zones or anywhere in game?
- When the latency is occurring what does your Home/World latency report. You can see this by placing your mouse over the red question mark next to your bags.

This information will help us greatly! Just make sure to collect it when the issue is at it's worst and during the time frame stated.

Thank you!


I'll do this right now cause it's becoming a absolute joke.

- Does this latency only occur in Battle for Azeroth zones or anywhere in game? Anyway

- When the latency is occurring what does your Home/World latency report. You can see this by placing your mouse over the red question mark next to your bags. Still a solid 35ms on Word and Home.
08/17/2018 07:39 AMPosted by Zuvykree
Howdy!

We are currently investigating this issue and need more information to narrow down the problem. When the issue is occurring please run a [url="https://battle.net/support/article/000027780?utm_source=internal-TechForum&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=solution"]WinMTR [/url] to host IP: 103.4.115.248 for 10 minutes. Post the results back here within code blocks </>. Other information we would like to know:

- Does this latency only occur in Battle for Azeroth zones or anywhere in game?
- When the latency is occurring what does your Home/World latency report. You can see this by placing your mouse over the red question mark next to your bags.

This information will help us greatly! Just make sure to collect it when the issue is at it's worst and during the time frame stated.

Thank you!


Yay, thanks for the response!

I will run this test as soon as i can, but in the meantime i will report that in my time playing over the past 2 days, i have noticed that the issue is much worse on the Zandalar continent than it is on Kul'tiras. A few hours ago Kul'tiras felt almost normal in comparison to Zandalar.

I have not spent any time outside of the BFA zones recently, so i cannot comment on that, but i do know that a few friends/guildies have mentioned that the Auction House seems to be very laggy, so assuming that they are not using the Brutosaur Auctioneer, that may indicate the issue is not isolated to BFA zones

Join the Conversation

Return to Forum