Companion app recruit problem

Mobile Bug Report
We are currently still investigating this issue and have not been able to reproduce internally so there is no update other than we're taking all this information and trying to understand why you are all seeing these issues. Currently the only other alternative we have is to request the following information for players so we can partner us with CS and take an indepth look at accounts..

    What version of the app: iOS or Android
    Build Version:
    Realm:
    Character Name:
    Did you know where you Rep/Troops were prior to collectin on the app?
    Did you go back and check in client after to ensure that it was actually missing?
    Screenshots


Once we have this information we will reach out if we see that any action is necessary. Our team is spending a lot of time trying to repro this issue with little success so updates will come when we have some solid information to report.
Still having this issue -

Recruitment will take the resources, show the troops as collectible, and then once you collect, they get green-check marked. But the icon does the loading circle, and doesn't finish loading. Resources expended, but slots do not fill.
Its corrected itself as of now at this time. Who knows it may happen again. I just know I'm out about 300 or so resources.
Hello All,

This is the information I need in order to get information pulled to see if we can track down the problem.
What version of the app: iOS or Android
Build Version:
Realm:
Character Name:
Did you know where you Rep/Troops were prior to collectin on the app?
Did you go back and check in client after to ensure that it was actually missing?
Screenshots
same problem here is my info not sure it will help but here goes:
OS: Android 8.0.0
Phone; Galaxy s9
app version: 2.0.27502
connection: WiFi
Was the slot spinning infinitely when work order was placed? YES
Was the slot spinning infinitely while collecting? YES
Did they disappear after collecting? Yes
Did you make sure that you did not receive them after relogging? Yes i have not placed any work orders either in game or in app since error detected.
Toon: Adrail-Baelgun
troop status prior to error: one Lightforged Dragoons with 1 remaining use, 1 Exodar Peacekeeper with two uses. 2 empty recruit slots. Champions; Magister Umbric (obtained just prior to error) Falstad Wildhammer, John J. Keeshan, Kelsey Steelspark(obtained after error occurred)
State of resource prior to error: approximately 100 after error 5 (more resources obtained through in game questing after error current total 70)
research lvl at time of error; rank 1 (swift landing)
location of toon in game when error occurred; my main was logged out in Stormsong valley at level 117 has since gained 2 levels.
opinion;( this error seams to occur during the following conditions in my experience. phone switches from WiFi to cell data for better connection, or when on a restricted WiFi network that meters traffic. i may be wrong in my coding theory but it would seam that the command prompt for the spawn timer on the troop is being transmitted either after that of the change to the quantity of resources or that the app is caching the change in resources to transmit when on a better connection and the prompt for the spawn timer is an immediate transfer that is being lost, so the system is processing the change to the resources but not the prior half of the transaction to begin the spawn timer.)
09/07/2018 03:23 PMPosted by Adrail
same problem here is my info not sure it will help but here goes:
OS: Android 8.0.0
Phone; Galaxy s9
app version: 2.0.27502
connection: WiFi
Was the slot spinning infinitely when work order was placed? YES
Was the slot spinning infinitely while collecting? YES
Did they disappear after collecting? Yes
Did you make sure that you did not receive them after relogging? Yes i have not placed any work orders either in game or in app since error detected.
Toon: Adrail-Baelgun
troop status prior to error: one Lightforged Dragoons with 1 remaining use, 1 Exodar Peacekeeper with two uses. 2 empty recruit slots. Champions; Magister Umbric (obtained just prior to error) Falstad Wildhammer, John J. Keeshan, Kelsey Steelspark(obtained after error occurred)
State of resource prior to error: approximately 100 after error 5 (more resources obtained through in game questing after error current total 70)
research lvl at time of error; rank 1 (swift landing)
location of toon in game when error occurred; my main was logged out in Stormsong valley at level 117 has since gained 2 levels.
opinion;( this error seams to occur during the following conditions in my experience. phone switches from WiFi to cell data for better connection, or when on a restricted WiFi network that meters traffic. i may be wrong in my coding theory but it would seam that the command prompt for the spawn timer on the troop is being transmitted either after that of the change to the quantity of resources or that the app is caching the change in resources to transmit when on a better connection and the prompt for the spawn timer is an immediate transfer that is being lost, so the system is processing the change to the resources but not the prior half of the transaction to begin the spawn timer.)


We are looking into these issues, did you happen to get a screenshot? We don't see this internally so we want to see what you are seeing.
I gave you all the information I had. You should be able to look into the game and see war resources being used for nothing. Just refund them please I could use them right now.
I do have a screen cap from the app but I am having trouble posting it
09/07/2018 09:41 AMPosted by Itzali
Hello All,

This is the information I need in order to get information pulled to see if we can track down the problem.
What version of the app: iOS or Android
Build Version:
Realm:
Character Name:
Did you know where you Rep/Troops were prior to collectin on the app?
Did you go back and check in client after to ensure that it was actually missing?
Screenshots


I am using the Android Version of the app
version 2.0.27502
Realm - Madoran
Character - Deivos
and I have lost 225 resources
it loops infinitely when trying to collect troops but consumes resources
I am using the iOS App
version 2.0.27488
Realm - Sargeras
Character - ibuyamplifir
I lost about 300 resources myself, though I dont have the exact amount
I also see it loop infinitely when trying to collect troops, get no troops, and resources are gone. I have confirmed that my resources are gone in game as well.

I opened a support ticked to get my resources back, and was essentially told to go pound sand and that there is no proof of the issue occurring. Clearly this existence of this thread contradicts that. I know that 300 resources isn't a lot to go farm, but c'mon. The customer service regarding this issue has been nothing but sub par. For reference, the ticket I had opened was #64999897.

Im not a dev over there, but I feel like you should be able to see the UPDATE statement to the sql table that holds character information, rather than try to track it from what I assume is a rest call that would initiate the update. (Obviously I am making huge assumptions of how the system is designed here)

I haven't purchased more troops since this happened (in game or through the app), so you may be able to trace the last resource count updates on my character and see compare that to the fact that I still have no troops. Not sure if it helps, but ill leave troops slots empty as to not clutter transaction logs.

Either way, this should be handled better.

Thanks,
-B.
Here are caps of the greyed out app, hopefully I can post them! Both troops failed and aren't available in actual game either ><

Here is a post of the caps. The picture doesn't change of the collect button, when I refresh app they are clear again and resources are gone :(

https://imgur.com/gallery/iA8w7xU

Please fix this and confirm my efforts have meant something!!
This just happened to me for the first time, wish I'd taken a cap. It happened two or even 3 times before I realised.

For me the collect button is live, I click and it goes dark with the green completion sweep just faintly starting but the animation is frozen. Troop doesn't appear and button stays that way. When you leave app and come back the slot is empty but you're still out the 25 resources.

I since finished a quest and now have 2 under construction, will take caps in case both now don't work!

I'm on iOS and the toon is on Dreadmaul; Roarschách. I haven't had a chance to check if the troops are available in game. I too believe it is connection related, the game seemed 'laggier' as I loaded it and i wasn't on Wifi when this happend.

Ah, phone juts chimed, we'll see if I can collect!
I have this issue. It’s so frustrating!! I didn’t realize I was wasting my war resources until I was like 300+ resources deep into trying to recruit. I try to do my missions while at work and logging into the game isn’t an option there. For me, I press recruit and then collect them and upon pressing “collect” a new load circle appears and never goes away. And if your phone goes to sleep while waiting and you come back it’s still loading. So naturally I try restarting the app and that’s when both the resources and the troops I should have recruited all disappear.

iOS or Android: ios
Type of phone: 7 plus
Version number of app: current
OS Version: current
Cell Data or Wifi: issue happens on both
Was the slot spinning infinitely when work order was placed? No
Was the slot spinning infinitely while collecting? Yes
Did they disappear after collecting? Yes
Did you make sure that you did not receive them after relogging? yes
Dont bother they dont care. They haven't fixed in weeks or refunded the resources.
For those who provided information, we're handing these screenshots and account info to our CS partners to help research. We will update as soon as we can track down what's going on.
09/15/2018 05:17 PMPosted by Roarschách
Here are caps of the greyed out app, hopefully I can post them! Both troops failed and aren't available in actual game either ><

Here is a post of the caps. The picture doesn't change of the collect button, when I refresh app they are clear again and resources are gone :(

https://imgur.com/gallery/iA8w7xU

Please fix this and confirm my efforts have meant something!!


This has been most helpful, thank you! QA will see if we can track down what's happening.

Join the Conversation

Return to Forum