Finished mission stuck

Mobile Bug Report
Hello,

Earlier today I sent my only follower on a mission, which is not only finished but I've also picked the reward in game, however the app is stuck on that mission, it says it's complete and that I need to pick the reward, but it won't let me, it also won't let me send my follower on any other missions because it thinks the follower is still on a mission even though she isn't.
It also won't let me recruit the two troops that expired because it also thinks these troops are on the same mission.

Info in case it's relevant:
I'm using the Android app on a Zenfone 3 with Android 8.0.1.
Auto updates are on, so the app is in the latest version available on the app store.
I have tried uninstalling and reinstalling the app but it did not fix the issue.

And on a side note: why was the legion class hall missions removed from the app?
Many people are still doing these for the rep tokens...
I too have issues completing missions. Only the first one I complete in the app works, any after that i have to do in game. Also recruiting troops sometimes takes a few app resets for me to accept new troops that are ready.

Galaxy S6 android 7.0
I started a mission in game last night. Today I tried to collect the mission in the mobile app and it shows the mission complete but won't let me collect. I've done this before with no problems so this is frustrating.
Yes I have had this problem for a week now. Blizzard support gave me a "we're too busy, here's wowhead" reply.

Join the Conversation

Return to Forum