Scrapper randomly stopping

Bug Report
having the same issue here. I can only scrap one, after which cursor turns into the blue gauntlet pointer. Clicking on items inside the scrapper box removes it from the scrapper, still with the blue pointer. Clicking on scrappable items in bag will initiate the scrapping. I have to do this one at a time. Very annoying!
same.
Same but not on all my toons. Works fine on this rogue but exactly as described in this thread on my druid.
Same for me. If I use the scrapper like a disenchant feature I can do it one at a time. But the ability to load and press a button does not work.
Prot warrior unable to continuously scrap without cursor highlighting and end up clicking items scrapping from bags.
08/23/2018 02:51 PMPosted by Sardønicus
I can confirm I had the same bug. I tried disabling addons, all things people suggested and no luck. I Finally found this thread, changed from PROTECTION to FURY and it started working fine.


Wow. I switched from Resto to Balance and now it works fine. What a strange bug.
switch from restro affinity talent and it works perfect.
This happens if you have a profession window open.

(Possibly the scrap button and the craft button are linked someway under the hood).

Close the profession window and it should work fine.
I was having the same problem on my survival hunter, switching to marksman fixed it. I wonder if it's something with the azerite gear.
Same problem on Bear druid and BM Hunter. Only windows open are scrapper and backpack. And its random 1-3 when it stops. Like someone else posted, I can click on the remaining items in the scrapper to remove the icon, then click on the items that were remaining in the backpack to scrap them. Have seen no difference in rarity (stops on greens and blues).
This has been happening since day 1 of the expansion, the very first time I tried multiple scrappings at one time. Only once did it ever get through all of them, next time it was back to the same problem. Now I scrap 1....piece....at....a.....time......
Stops for me after each item. If you then click on an item in your inventory with the glowing cursor, not in the scrapper, it will scrap that item so I feel like this could be a "feature." Personally I'd rather have it auto-scrap 9 items at once than have to manually click them each in my inventory.

I don't have a profession window open and it still happens. I've tried opening and closing my inventory but the same issue persists. It's happened on both of my warriors, in arms and prot, as well as my shadow/disc Priest.
holy crap changing specs does fix this on my warrior to, i was prot switched to arms and it worked. please figure out the cause of this blizz. In the mean time at least i figure it out now
Same Problems
It seems the fix is to change specs.

In Survival, I can't scrap more than 1-2 things, but as BM, I can.

If you're having problems, switch to your offspec.
same problem, was scrapping for some expulsom but the scrapping stops after two items
It seems to be related to any talents that update when a new player enters, for example on my prot warrior I specced out of into the fray so it wasn't adjusting the haste buff everytime someone came in or exited the scrapper and it's now working perfectly. Spec back into Into the Fray and the issue occurs again. Solution seems to be to just swap away from any talents that apply some type of buff to yourself / those around you when someone comes near you and swap back when you're done scrapping.
On my hunters its working flawlessly, but my druids not so much.
Good to see a work around has been found for now at least.
Im on a Balance Resto and I can only scrap 1 at a time, then my girlfriend is Bear Feral and has no issue

Join the Conversation

Return to Forum