App Crashes

Mobile Bug Report
A week and no reply. Not even an acknowledgement. Looking an awful lot like they just don't care.
I've posted about this in several places. Never a respond. Almost New S9+. Android 8.0.0 or whatever. So glad they care so much these days.

Also. Love the fact that this isn't listed in known issues. Like most other bugs recently. Let's just pretend it doesn't exist and no one will know.
This started happening immediately after I added follow equipment a few days ago though probably unrelated. I can no longer log directly into Joker as the app will crash. I’ll load it back up and I’ll get the message “Character already logged in on this account.” I’ll switch to a level 110 alt and log in about 75% of the time. I’ll be able to switch characters back to Joker maybe 5-10% of the time but normally the app crashes.

Apple iPhone 6
iOS 11.4.1
I have this problem. Droid Maxx. I've uninstalled and reinstalled and rebooted my phone. This is ridiculous.
Well, after two weeks without any acknowledgement I've given up any hope that Blizz is working on this, or that it will ever be fixed.

While my guildmates are making leaps and bounds with their follower missions, we are stuck completing nearly nothing.

I really am enjoying the new content, but not being able to complete missions remotely has just soured me on the whole experience.

This is obviously not a priority for Blizz.

I deleted the app. I don't need non-working apps taking up space on my phone.

Sad.
Same issue. Crashes as soon as I try to connect to Fyonna.
Same as all of the above. Galaxy S4, Android 4.4.4. Legion app ran great, BFA app crashes at the azerite screen.

Of course I'm not running the "latest non-beta version of Android" (the official minimum operating system) but then, so are about 95% or more of android phones.
IOS same issues with crashing and or not loading.
Hello All,

Sorry for the delayed response, but I was out due to illness for a few days and unfortunately I was not able to get on to reply.

Some of these issues are occurring due to unsupported devices, others we're trying to repro internally. Please know we're actively investigating this issue and I will update with findings as soon as I can.
08/29/2018 05:43 AMPosted by Valentin
Same as all of the above. Galaxy S4, Android 4.4.4. Legion app ran great, BFA app crashes at the azerite screen.

Of course I'm not running the "latest non-beta version of Android" (the official minimum operating system) but then, so are about 95% or more of android phones.


I'm not so sure 95% is a valid number. But, 9.1% currently use your version which was no longer supported and updated by Google as of October 2017 (10 months). https://en.wikipedia.org/wiki/Android_KitKat

That said, it may be virtually impossible to support something 4 major revisions back as features change in the OS (even true in iOS). Most companies tend to support n-1 or n-2 where n=current major release (Meaning 6.x would be at the very least supported and 8 would be current.)

I saw a few weird issues, but not crashing as such. It did on occasion say it couldn't login in the last 24 hours - though no constancy in that regard.
Need Android 5.0 to run it now. Mine is 4.4.4 and won't update, so I'm just SOL like you and lots of other people. Yay Blizz!
iPhone 6s ios 11.4.1

Legion Wow Companion always worked just fine.

Now it says "Downloading,,," gets about 50%, and after a very long while says "unable to download data from the device"

I've uninstalled wow companion and reinstalled several times.
Did hard reset of my phone.

haha! sneaky... while I was writing this, I waited to verify the wording of the problem...and... for the first time I got to the login screen

Well, that was short lived excitement. Log in forces all CAPS even when I paste my password so I'm unable to log in. I suppose I could change my pw to all CAPS,

After 3 or 4 failed log in attempts, I successfully logged twice in despite the pw looking like all CAPS. Seems to be working fine now.
08/29/2018 11:10 AMPosted by Itzali
Hello All,

Sorry for the delayed response, but I was out due to illness for a few days and unfortunately I was not able to get on to reply.

Some of these issues are occurring due to unsupported devices, others we're trying to repro internally. Please know we're actively investigating this issue and I will update with findings as soon as I can.


Can you list unsupported devices?

I have an Asus ZenFone 2 (ZE551ML) running on Android 6.0 and the WoW Companion app was running fine until Patch 8.0 came out. Now the app loads up and closes within seconds. I've cleared the catch, uninstalled, and reinstalled it with no avail! :(
POSSIBLE SOLUTION

I found that if I turn off wifi and run on 4g, it stops crashing. If I turn wifi on, it crashes again. Try that. I'm running a Samsung Galaxy s7 edge.
Same issue, using the Asus ZenFone 2 (ZE551ML). Apparently there's a lot of people with the problem on this device.

Any updates?
Hello All,

We're trying to reproduce this issue internally but are not seeing it at this time. Currently we're trying to track down another device that we can test on. Will update when we get some information.

Join the Conversation

Return to Forum