Saving Xibala - bugged and cannot complete

Bug Report
I went to Xibala in Zuldazar for the "Saving Xibala" quest. I clicked on the gryphon ("Ride the Gryphon" portion) and IT LEFT WITHOUT ME. Seriously. Now the Xibala camp is phased as if it still thinks I'm on the quest, and I can't reset it. Help!

(Yes I've tried relogging, and even going far away from Xibala... it won't reset. At least two other people are complaining about this on Wowhead, just FYI.)
Im in the same boat at about the same time. No resetting/zoning/logging has helped
wtf is this garbage.
OK, got it done. but there is only two out of the four or five that can be destroyed on the boat
Did you just wait and a gryphon respawned or did you have to do it without?
My gryphon is also missing.
09/18/2018 09:40 PMPosted by Borrum
My gryphon is also missing.


And the camp and surrounding area is zoned as well.
Fixed by swimming out there and judgment-tagging things until they were killed by others, I assume. Then I was teleported back to camp. Hope this helps.
Was trying to do this quest as a shaman. Was in ghost wolf form when I tried ot mount the gryphon. It left without me and I can't seem to even attempt to mount it again. Even went back to Boralus and sailed back, nothing. Ever since doing this, most of the NPCs in the camp seem to be phased out now too.
same thing happen to me on my hunter was flying out to boat then it vanished on me
Had this sort of bug on me earlier. Could not do any damage at all to two of the machine things on the boats. After letting the gryphon do 8 or so turns around the ship, I finally flew it back down, logged out, logged back in and tried again. It finally worked then ... but this quest has some issues with it.
Cant even zone into the motherlode.
I understand Blizzard is a small indie company, but please do something to fix this issue : (.
same i got bugged as well speechless
Had to land land, log off, and to return to the quest to damage the catapults. They wouldn't take damage the first go around.
So uh.
I let it sleep over night
and guess what!
still broken and no replies from blues or anything in this thread wtf is going on
Same problem for me just now, tried everything - reload/relog/flying out/hearthing/flight whistle.

/leavevehicle - says you can't do that right now.

Submitted ticket and waiting.
This is trash. So frustrating.. This is at least the 5th quest I've come across this week that is bugged.
Same garbage, lost some good gear too.

When the gryphon leaves without the player it marks the objective of mounting the gryphon as complete and then it does not respawn.

Dying, relogging, changing zones, reloading ui, does nothing.
I just had a friend join my group and do the quest. I followed in the water beneath him and was able to get completion.

Join the Conversation

Return to Forum