Nat's Fishing Chair

Professions
Blizzard, this is truly a massive issue and something clearly overlooked as I and many other fishermen around Azeroth have submitted bug reports about this...

Nat Pagle's Fishing Chair, the one that we worked so hard to obtain in order to sit in comfort, in luxury, with a cool drink in our holder and some shade on our weary heads... is broken.

Yes you heard me. It's broken.

What happens when it's used?

There is nothing but a fish. Just a non-interact-able green fish.

Please, please resolve this glaring, horrifying bug so that all of us that enjoy the wonderful profession that is fishing can once again have our shade and drink cooler rather than sitting in the dirt.
Yep tried summoning to fish in comfort and style but ... Definitely miss it!
spent a lot of time to get the rep.
Finally got the chair, all excited to see it, and I get: [Nat's Dead Fish].
Disappointed does not even.... (heartbroken, now I just stare at the fire in the Inn and weep quietly)

looked up on wowhead, seems there were issues with it blocking movement....

https://www.wowhead.com/item=86596/nats-fishing-chair#comments

magickmann on 2018/07/20 (Patch 7.3.5)

"Fishing Chair and Nat's Fishing Chair have been temporarily converted into objects that are not chairs, while a bug with their functionality is fixed. They will return to their former function in a future patch. " players were placing several of these in front of auction house entrance blocking others from going in or out. Im sure there was other places being blocked and enough ppl reported this.

Join the Conversation

Return to Forum