I don't want new models - have pride being ugly

General Discussion
I see a lot of posts about new models for races. I had to buy a new PC with BfA. Actually, I was having some trouble all the way back in beta. Anyway, when you do any visual upgrades, you're pushing older systems onto the scrap heap. It's best not to do it for shallow reasons, like "I'm tired of how my character looks."

Your characters have been fighting for a long time... they should all have ugly scars and cauliflower ears.
Nah.

Out with the old, in with the new.
You can turn off new models my guy. It's a option in the settings
11/08/2018 02:08 AMPosted by Grezik
Nah.

Out with the old, in with the new.


Well, your character is an exception...
11/08/2018 02:10 AMPosted by Monrith
You can turn off new models my guy. It's a option in the settings

No you can't, they disabled the checkbox to use old models at the start of BfA.
11/08/2018 02:07 AMPosted by Bessie
I see a lot of posts about new models for races. I had to buy a new PC with BfA. Actually, I was having some trouble all the way back in beta. Anyway, when you do any visual upgrades, you're pushing older systems onto the scrap heap.

Taurens have already been updated. They're not going to update you again and tax your computer further. Whatever you look like under that helmet now, that's the way you're going to remain for the next decade or so. (Assuming the game runs that long)

The only models being updated this expac are worgens and goblins, and neither is really a common enough sight that they're going to further slow down your computer with a few more polygons.
Ever wonder why most humans wear helmets? lol.
11/08/2018 02:10 AMPosted by Monrith
You can turn off new models my guy. It's a option in the settings
Did you know that that option for most races has been taken out slowly one by one without notice after a few patches or when the next Xpac came out?

Not sure if there still is any race left that actually has that option available.
At least all the races I play doesn't have it anymore.
I am my scars!
Speak for yourself. I cant wait to be able to close my mouth.
no company should be supporting 20 year old hardware.
11/08/2018 03:39 AMPosted by Alaeis
Speak for yourself. I cant wait to be able to close my mouth.

Right? This perma-snarl has gotten old.
Pretty sure they maintain relatively the same poly count, but just update the visual textures on most models. Shouldn't be taxing on most computers, maybe if you're using like a 10+ year old graphics card/computer.

Join the Conversation

Return to Forum