Justice for the Fallen

Bug Report
10/09/2018 12:03 PMPosted by Clinkz
It looks like if you click the item in your bag instead of on the quest tracker, it works. I had the same thing happen in LFR. I didn't get credit for it and the item disappeared. I dropped the quest while I was still in the raid group and someone shared it again. I clicked the item in the bag instead of the quest tracker icon and I got credit for it.


This worked for me and multiple people in my LFR, after using it from the quest tracker bugged.
I also can't get it to complete for me. Tried different difficulties, using the glaive from my bags etc.
I concur
I guess you don't get credit for being in a "Raid" the quest is designed for solo play is what one of my guildies gathered from how the glaive launched but no credit for the quest was given. So I guess some tinkering is needed.
Three toons in a row this has happened. Which means ANY testing at all should have caught this bug before going live. Get it together QA team.
10/09/2018 10:10 AMPosted by Zengashi
Same
This expansion should just be titled Bugs For Azeroth at this point.

I did LFR and down Myth and got DC'd repeatedly during G'hunn. I had to restart my computer and then I had to take rez sickness in Zandalar and wait. Second go in LFR we downed Myth and then for G'hunn we took three attempts but got down. Then I used the glaive quest item and still 0/1 completed. WHAT THE HELL? I wasted over an hour on this retarded broken quest.

And then trying to post this response to the forum, I get the "An error occurred" notice and had to log out and back in to post... I can't even report a bug on the bugs forum. RAGE!
Same issue. I wonder how these important story line quests go live without any actual testing tho..
Same. Please give Bloodied Glaive.
Same issue. Used from bag, didn't work. Waah waaah
Yea same issue here and for others in the group.
Same, would not complete
Same. had people in group have it work but not for me.

Simplest quest structure possible. Kill X, use Y. Can't even trust that to be working properly these days.

What's really bad about it is while you can do it in LFR and it's not exactly hard it is extremely TIME CONSUMING and no one bothered to make sure the quest worked well enough you wouldn't have to down raid bosses multiple times to get it to work.

THAT is unacceptable.
The quest bugged for me on LFR. But I abandoned the quest, ported out of the instance, got the quest again, ported back to the instance and it let me complete it! Just make sure someone stays in the instance so you can get back in.
I did it in lfr and got credit.

Didn't use quest tracker to do it , put glaive from bag on open key bind slot and did it that way
Support says the bug is fixed. If you tried and failed you should probably abandon and re-acquire the quest before trying again.

Join the Conversation

Return to Forum