macOS update message when launching WoW

Mac Technical Support
Is there a way to suppress the warning regarding current OS version when launching Warcraft?

I'm currently on 10.13.6 and recently I started getting the message that there is an available update to my OS which will increase stability and whatever. I'm not unfamiliar to the message, I have seen it before with other updates to 10.13. I'm planning the update to Mojave at some point, but would like to stop this annoying message, it prevents auto-switching to WoW as it launches.
App Store > Preferences

Your can adjust automatic updates from here.
10/12/2018 05:54 AMPosted by Tavlina
App Store > Preferences

Your can adjust automatic updates from here.


That won't stop the nag warnings while he's on 10.13.6. And given what's been happening with Mojave I certainly wouldn't turn on automatic updates.
automatic updates wouldn't install 10.14 over 10.13.6 far as I know.

Shouldn't even be seeing update messages with 10.13.6, certainly not from blizzard

I'm on 10.13.6 and getting no such messages.

Are you sure you are on 10.13.6 and not being told to update TO 10.13.6?
Marked As Solution
10/14/2018 12:51 AMPosted by Omegall
automatic updates wouldn't install 10.14 over 10.13.6 far as I know.

Shouldn't even be seeing update messages with 10.13.6, certainly not from blizzard

I'm on 10.13.6 and getting no such messages.

Are you sure you are on 10.13.6 and not being told to update TO 10.13.6?


My computer was updated to 10.13.6 using an update from appstore and then each of the security updates afterwards. When launching WoW, I would get a message stating that I was running 10.13.6 and there were available updates to improve stability/performance/blah blah blah. The only real annoyance from it was that it prevented autoswitching to WoW and I have to acknowledge the prompt and click WoW from my dock or Option+TAB to it.

Earlier this week I did a reinstall of 10.13 and updated to 10.13.6 using combo, then installed security updates and the message no longer appears. crappy workaround but it worked.

Join the Conversation

Return to Forum