Freezing Profession windows

Bug Report
Hello,
I have noticed lately while in game if I open a window for any professions (first noticed with cooking) my screen will freeze for ~5 seconds or so. I tested on different characters and one thing I did get to occur consistently was after immediately logging in I can open up my cooking and there was no issue. I close it then open it a second time and the freeze will occur. If I stay logged in and change characters the freeze will happen on the first time I open a profession window. Please note, it is not the window that opens by pressing 'K' it is the actual professions.

I have all my hardware drivers updated, I turned off my Firewall and antivirus, . Latency averages about 40-45ms both Home and World. While in a major city with a lot of other players I can maintain a decent FPS around 48 with my graphics all turned up high and some Ultra High.

I also tried https://us.battle.net/support/en/article/7549 and started the game up with no addons and the issue remained. Also, not sure if related but the game also freezes when changing realms.
This issue is also being discussed in the professions forum here https://us.battle.net/forums/en/wow/topic/20768616937?page=1

I've been having the same issue. I deleted the cache folder, disabled all addons (on an alt I don't care about with a profession). The freeze is shorter, but still there.

One thing I have now noticed is that after deleting the cache, each character I login to can view one of their professions instantly, the lag (lesser, but still an issue) returns on the second viewing of a profession. This happens if it's the same profession or a different one.

There is very little lag when switching professions (clicking between them).
Same problem as the rest. Tested on 2 different PCs, one with a fresh install of WoW with no addons installed. Fine the first few openings, then starts to degrade.
Just saw a thread on this in GD, adding my account to list with this bug.
This bug is also mentioned here:
Profession window slow or does not open
https://us.battle.net/forums/en/wow/topic/20767658718
I'm having this issue as well. I've done all the "fixes" for it but it comes back after a few hours. Hope we can get a fix soon!
I'm having the same issue on every Character.
Commenting just for notifications of resolution. I also have tried all suggestions, but the issue still persists. I have deleted the WTF, CACHE, and Addon contents, but it does not resolve the issue. Any further information i can gather, to assist, I will gladly provide.
11/03/2018 04:32 PMPosted by Ruke
This issue is also being discussed in the professions forum here https://us.battle.net/forums/en/wow/topic/20768616937?page=1

I've been having the same issue. I deleted the cache folder, disabled all addons (on an alt I don't care about with a profession). The freeze is shorter, but still there.

One thing I have now noticed is that after deleting the cache, each character I login to can view one of their professions instantly, the lag (lesser, but still an issue) returns on the second viewing of a profession. This happens if it's the same profession or a different one.

There is very little lag when switching professions (clicking between them).


I'm having the same issue, with the same behavior as described above: the first profession window I open is instant, but if I close it and open another profession window, it takes 2 seconds (and my entire game freezes during this time). If I leave the window open, I can switch between professions quickly and without issue. None of the steps suggested in the various threads about this issue appear to make a difference for me.
Been having this issue since BfA launch, it's gotten worse. Deleting/renaming cache and wtf and disabling all addons had minimal effect. Freeze with addons is about 10 seconds, without it's about 2 seconds. character select screen freeze is there no matter what, usually between 3-15 seconds.
has there been any response to this?
No response yet.

I've also noticed freezing just before a character appears on the login screen which may be another issue. Others seem to have noticed it too > https://us.battle.net/forums/en/wow/topic/20766536670#post-12

I've run a scan and repair which did a little downloading so /something/ was.. done? The logs don't show any changes.
11/12/2018 12:53 PMPosted by Robotj
has there been any response to this?


I have not seen a response. I would just like to know if this is being worked on myself.
I have experienced freezing when I opened any profession after the first time. Oddly once the profession window is open, I can switch to another directly (ie from smelting window to blacksmith window) with no lag. But if I closed the first one then opened the other one, freezes!

Almost looks like a glitch with profession UI is causing the client to freeze after it's opened the first time.

Join the Conversation

Return to Forum